UCCX 5.0.2 Recording issues

Unanswered Question
Jul 21st, 2009

Trying to set up silent monitor and record. I have set up the 2nd nic on the uccx server and have configured a monitor port on the switch. Source port is connected to 7942, destination port is uccx server. I ran the postinstall and selected the 2nd nic as the monitoring interface. When I try to record through a work flow or directly from supervisor desktop, the raw files are created but all are 1K and no audio is heard when they are played back.

Things I've tried while shooting in the dark...

Desktop Administrator

-Call Center 1 -> Enterprise -> VOIP Monitor

Checked enable Desktop Monitoring, Unchecked Desktop Monitoring, Selected default monitoring server, unselected default monitoring server.

-Call Center 1 -> ... -> User Interface -> IPPA

Unchecked enable ippa recording, checked enable ippa recording.

Primary NIC:

Monitoring NIC:

switch config

monitor session 1 source vlan 11 (voice vlan)

monitor session 1 destination int fa0/16 (montoring nic)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
joesnyde Tue, 07/21/2009 - 09:14

Check to be sure that the binding order is correct on the UCCX server, Primary NIC (Application Traffic) should be first in the list, then the Monitoring NIC. Open Network Connections -> Advanced -> Advanced Settings.

Also here is a couple of links that may help out.

Configure and Deploy Silent Monitoring and Record in CRS


Desktop Monitoring Checklist and Troubleshooting Guide


acomiskey Tue, 07/21/2009 - 09:31

I've been over both those docs several times. I did however change the binding order, I will post back when I am able to test it out. Thanks!

acomiskey Tue, 07/21/2009 - 09:52

Changed the binding order...no change, still getting silence.

joesnyde Tue, 07/21/2009 - 10:01

What is the current deployment setup regarding the network, where do the phones sit in relation to the UCCX server. How many switches? I know we had a configuration issue with the spanning, were are using RSPAN. I will try to find out what we did to resolve the issue as I was not the one that configured the switch.

Please take a look at the guide for troubleshooting monitoring and recording. This guide is a little more detailed.

joesnyde Tue, 07/21/2009 - 10:06

What is the recording count set to on the UCCX server?

Select System > System Parameters and set the number of the recording count appropriately.

joesnyde Tue, 07/21/2009 - 10:19

Make sure you have disabled "Advertise G 722 codex" on the agent phone and make sure your settings in Cisco Unified CM are for the G.711 or the G.,729 codex. Although Cisco Unified CM 6.0 supports the G 722 codex, CAD does not.

acomiskey Tue, 07/21/2009 - 10:28

Phone and uccx server nics are all on same switch.

UCCX Server - Primary

interface FastEthernet0/3

switchport access vlan 11

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust cos

auto qos voip trust

spanning-tree portfast

UCCX Server - Monitor NIC

interface FastEthernet0/7

switchport mode access

spanning-tree portfast


interface FastEthernet0/13

description CSR

switchport access vlan 2

switchport mode access

switchport voice vlan 11

service-policy input AutoQoS-Police-SoftPhone

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

auto qos voip cisco-softphone

spanning-tree portfast

marina.kaminski Wed, 07/22/2009 - 02:21

Did you try to connect a sniffer (or use the network monitor on the server itself) to see if the packets are actually delivered to the server?

joesnyde Wed, 07/22/2009 - 12:02

Here is the cofiguration we used


vlan 294

name IS_Monitoring_RSPAN_VLAN


vlan 289

name CS_Monitoring_RSPAN_VLAN


monitor session 2 source vlan 289 , 294

monitor session 2 destination interface Gi7/15


vlan 289

name Monitoring_RSPAN_VLAN



monitor session 1 source interface Gi0/15

monitor session 1 destination remote vlan 289


vlan 294

name Monitoring_RSPAN_VLAN



monitor session 1 source interface Fa2/0/25 - 26

monitor session 1 destination remote vlan 294

acomiskey Fri, 07/24/2009 - 06:28

Managed to get it all working. Thanks for all the assistance.

glovato Fri, 08/21/2009 - 13:32

i am having this exact issue. Would you mind letting me know what you did to fix this? I woudl really appreciate it.


This Discussion