MGCP FXO Port registration Rejected

Unanswered Question
Jul 21st, 2009


I am trying to configure an MGCP FXO Port

amd each time registration is rejected what am i doing wrong. see attached.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
testeven Tue, 07/21/2009 - 08:19


Seems you did not enable mgcp on any dial-peer. In fact there are no dial-peers configured.

You need to bind the MGCP application to the voice port. It should look something like:

ccm-manager config

dial-peer voice 100 pots

service mgcpapp

port 0/0/0

Please refer to:

I hope this helps, if it does please rate!



Michael Owuor Tue, 07/21/2009 - 08:39

To add to Teresa's good notes (+5), you could additionally be running into a domain name issue. The domain name for the gateway configuration on CallManager must be the same as on the gateway. Try either:

1. Changing the gateway name in CUCM to just ocgr22, or

2. Configuring the domain name on the MGCP gateway by entering the command "ip domain name "

Also, since the hostname of the CUCM is used in the 'mgcp call-agent' command, add the command 'ip host OCTUC01' to allow the gateway to resolve the hostname to the actual address.

Hope this helps.



Okechi Awujo Tue, 07/21/2009 - 23:20

hi Teresa, Good point .. but the GW is configured to download it's config from the CM


ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold bind Loopback0

ccm-manager config server

ccm-manager config


when you issue the command show ccm-manager ...

Priority Status Host


Primary Registered OCTUC01 (

First Backup None

Second Backup None

Current active Call Manager:

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 08:16:51 bst Jul 22 2009 (elapsed time: 00:00:13)

Last MGCP traffic time: 08:16:51 bst Jul 22 2009 (elapsed time: 00:00:13)

Last failover time: None

Last switchback time: None

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

TFTP retry count to shut Ports: 2

Backhaul Link info:

Link Protocol: TCP

Remote Port Number: 2428

Remote IP Address:

Current Link State: OPEN


Packets recvd: 101

Recv failures: 0

Packets xmitted: 159

Xmit failures: 0

PRI Ports being backhauled:

Slot 0, VIC 3, port 0

Configuration Auto-Download Information


No configurations downloaded

Current state: Waiting for commands

Configuration Download statistics:

Download Attempted : 59

Download Successful : 58

Download Failed : 0

TFTP Download Failed : 2155

Configuration Attempted : 8

Configuration Successful : 0

Configuration Failed(Parsing): 0

Configuration Failed(config) : 9

Last config download command:

FAX mode: disable

Configuration Error History:

voice-port 0/1/0

echo-cancel coverage 8


voice-port 0/1/0

echo-cancel coverage 8


voice-port 0/1/0

echo-cancel coverage 8


voice-port 0/1/0

echo-cancel coverage 8


voice-port 0/1/0

echo-cancel coverage 8


voice-port 0/1/0

echo-cancel coverage 8


voice-port 0/1/0

echo-cancel coverage 8


voice-port 0/1/0

echo-cancel coverage 8


c.marcillat Tue, 07/28/2009 - 00:39


I have exactly the same problem with the gateway 881 SRST.

I need help please !

Thanks !

kc-ussugar Wed, 10/21/2009 - 08:29

I've seen this scenario resolved by forcing the config from the VG side - OUT of config do the following:

ccm-manager config-download check reset

sysjes Wed, 10/21/2009 - 12:01

Your TFTP downloads are FAILING. Try this:

ip tftp source-interface loopback 0

emresumengen Tue, 11/29/2011 - 01:09

Hi everyone,

I don't know if the issue is solved for everyone (hence no replies since 2009), but I wanted to share what I did, so that everyone can benefit from that...

On my setup, my FXO and FXS port registrations (of the 881SRST) were failing and this didn't change with CCM configuring the device or with manual device/dial-peer config.

I also did receive config. errors that are complaining about "echo-cancel coverage 8"... I overcame this error with disabling echo cancellation on ucm config.

Then, in UCM, I set the 881SRST gateway to have NM-4VWIC-MBRD on module slot 0, VIC3-4FXS/DID on subunit 1 and VIC2-1FXO on subunit 3. Then I configured dial-peers for all ports manually on the router. After this, I could successfully register the devices I created on UCM. The dial-peer config I did for each port was basically this:


dial-peer voice 100 pots

service mgcpapp

port 0

description FXS PORT 0 - aaln/S0/SU1/0@


By the way, the ports you create on UCM should be Loopstart... At least it was on my physical config

Hope this helps someone.


andresfmg Thu, 12/15/2011 - 13:40

I have a simple question, the 881SRTS router can be register with a CUCM 7 and work has a remote gateway (SCCP,MGCP or H323) with FXO lines ?

emresumengen Thu, 12/15/2011 - 23:57

Haven't tried it with UCM7, but as far as the datasheet states, 7.1(5) should be fine...

"For SRST features for IP phones, refer to the SRST data sheet at:

Cisco Unified Communications Manager support for analog and digital ports come with Releases 7.1(5), 8.5(1), and 8.6(2)"

By the way, I'm running one with UCM8.0(3) as an MGCP gateway right now...

emresumengen Fri, 12/16/2011 - 06:13

Yes, the 881SRST has 1 FXO and 4 FXS ports, along with 1 FE routed + 4 FE switch ports... (That's a lot of ports, for a small fixed router )


This Discussion