EIGRP & looping packet

Unanswered Question
Jul 21st, 2009

I have 2 4506E sup2+ connected with a number of vlans configured for HSRP. I changed to of the vlans subnet masks, verified the configuration on both, and now i cant ping the HSRP VIP address on both of these vlans.

When tracing & Showing ip route, to one of the physical interfaces it loops between vlans instead of displaying it as direclty connected.

Any ideas beside clearing the EIGRP.

Jul 21 16:03:51 gmt: %IP-3-LOOPPAK: Looping packet detected and dropped -

src=10.12.11.11, dst=152.x.x.x, hl=20, tl=84, prot=1, sport=0, dport=0

in=Vlan65, nexthop=10.72.105.3, out=Vlan64

options=none

-Process= "IP Input", ipl= 0, pid= 77

-Traceback= 10A3CC28 10A3CECC 10A3EA88 10A3F8E8 10A3D438 10A2E42C 10A2E8E8 10A2D

670 10A2D8D4 10A2DB98 10626460 1061DC68

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
vmiller Tue, 07/21/2009 - 09:32

Did you clear IP routes ?

Worst case, you may need to do a reload,

or a power cycle.

neilobrien Tue, 07/21/2009 - 12:31

After changing the mask of the VLAN interfaces, is the hsrp address still in the subnet? Did you change the routing protocol to reflect the new mask for the subnets?

Or are there any routes/helpers that are attempting to forward to an ip address that was outside the subnet but now is inside after the mask change??

BeechLiam Wed, 07/22/2009 - 02:14

I have verified the HSRP is still in the subnet. and routes and helpers.

The EIGRP is a stub with no auto-summarize, the subnet is subnetting down to 6 vlans. but I have it advertised as a full /24. the EIGRP protocol keep trying to establish new adjacency for the vlan , stating the vlan is down but the vlan is up up.

BeechLiam Wed, 07/22/2009 - 02:31

Both vlan interface are showing as UP UP ,even though the EIGRP logs specify the vlans are down.

SW1

interface Vlan4

ip address 152.62.76.66 255.255.255.192

standby ip 152.62.76.65

standby preempt

!

interface Vlan5

description Prod_servers

ip address 152.62.76.130 255.255.255.192

standby ip 152.62.76.129

standby preempt

Router EIGRP 0

NETWORK 152.62.76.0 255.255.255.0

no auto-summary

eigrp stub connected summary

sh log

Jul 22 10:26:15 gmt: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 152.62.76.67 (V

lan4) is down: Interface Goodbye received

Jul 22 10:26:20 gmt: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 152.62.76.67 (V

lan4) is up: new adjacency

Jul 22 10:26:41 gmt: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 152.62.76.131 (

Vlan5) is down: Interface Goodbye received

Jul 22 10:26:45 gmt: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 152.62.76.131 (

Vlan5) is up: new adjacency

-------------------------------------

SW2

interface Vlan4

ip address 152.62.76.67 255.255.255.192

standby ip 152.62.76.65

standby priority 50

standby preempt

!

interface Vlan5

ip address 152.62.76.131 255.255.255.192

standby ip 152.62.76.129

standby priority 50

standby preempt

Router EIGRP 0

network 152.62.76.0 255.255.255.0

no auto-summary

eigrp stub connected summary

sh log

Jul 22 10:27:38 gmt: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 152.62.76.66 (V

lan4) is down: retry limit exceeded

Jul 22 10:27:41 gmt: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 152.62.76.66 (V

lan4) is up: new adjacency

Jul 22 10:28:04 gmt: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 152.62.76.130 (

Vlan5) is down: retry limit exceeded

Jul 22 10:28:07 gmt: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 50: Neighbor 152.62.76.130 (

Vlan5) is up: new adjacency

neilobrien Wed, 07/22/2009 - 05:13

Hi - why do you have them configured as stubs. this is most likely your problem. Stub routers should only be "spoke" routers on the edge of a network.

The eigrp errors are telling you that EIGRP is tearing down the adjacency itself (goodbye packets). When a router is configured as a stub, it advertises a summary route, which resets the neighbours. I'd say your routers are in a little loop of sorts.

remove the stub commands and the neighbours should come up and stay up.

BeechLiam Wed, 07/22/2009 - 05:41

The 4506 switch sup + 2 only supports stub eigrp. The preferred option was to upgrade to full EIGRP. The stub command can stay, but I cleared the ip eigrp neighbors on the 4506 , which had resolved the loop issue. but I have to put a static on the Gateway router for the network as the stub looks like it wont advertise the route to the gateway for the 152.62.76.0 network.

In the meantime , I have the fix. Clearing the ip eigrp neighbors and now the route is learned as a /26 instead of a /27 as previously.

Thanks for the help folks

Actions

This Discussion