1252 VLAN not working

Answered Question
Jul 21st, 2009
User Badges:

I have a single AP1252 unit with two SSID's (Private=VLAN1 & Public=VLAN3). The SSID:Private is the native VLAN and works just fine. The SSID:Public has client problems. From the AP, I can ping my VLAN3 gateway on the router. Clients can connect to SSID:Public and in the GUI, it shows the association. But the client can't get an DHCP address from SSID Public. I set a static IP address on the client on VLAN 3, but still can't ping the gateway. I'm not sure where I went wrong.

Correct Answer by Roman Rodichev about 7 years 8 months ago

Your configuration looks perfectly fine. Something is not right on your switch/router/dhcp side.


SWITCH, make sure you are trunking:


interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,3

switchport mode trunk

spanning-tree portfast trunk


On router, make sure you got helper pointing to DHCP, or you have a DHCP pool configured for vlan 3.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Roman Rodichev Wed, 07/22/2009 - 10:27
User Badges:
  • Gold, 750 points or more

Your configuration looks perfectly fine. Something is not right on your switch/router/dhcp side.


SWITCH, make sure you are trunking:


interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,3

switchport mode trunk

spanning-tree portfast trunk


On router, make sure you got helper pointing to DHCP, or you have a DHCP pool configured for vlan 3.


pirateoftheairwaves Sun, 08/23/2009 - 00:55
User Badges:

hi roman,


i basically have the same ap config as the one posted but without the gateway ip and is working fine. i've all the ap's on an ap mgmt subnet and separate vlans for the different types of users (employee and guests). just wanna ask, what is purpose of the gateway ip address? what are the consequences if it is and it isn't set?


thanks!


Actions

This Discussion