Help!! Telephony Setup Wizard stops at 95% & cannot reload software!

Unanswered Question
Jul 22nd, 2009


It's my first time configuring an 8-user UC520 with five Cisco 7960 handsets and two Cisco 7936 conference units.  I'm using the latest CCA 2.0(1). I was having trouble with the factory-installed software - not recognising handsets, etc., so upgraded with the latest software package (7.0.3) - the total package - which was successful.

All was ok after this - all handsets recognised and I experimented with a few different configs.  Anyway, to remove any problems that my experimentation might have caused, I wanted to retore the factory config and start again to implement the final configuration.   I couldn't get the restore to factory settings to work using CCA - it kept retaining the previous information - so I did it in the end using the CLI and instructions posted elsewhere in this forum.  All good - all restored to defaults EXCEPT now when the telephony setup wizard starts, it gets to 95% of loading and freezes, so the wizard cannot be used. I have tried rebooting several times and always the same.  So I thought, ok, I will try reloading the same 7.0.3 software package again, as someone else in these forums did when he had the 95% problem, but I can't.  When I try clicking on the device to upgrade in the maintenance window, I get a message saying that it is in the process of loading voice data or something, please try in a few seconds (sorry - dont have it in front of me as I write this). However, it continues to give the same error message, thus not allowing me to reload the software.

Does anyone have any ideas? I want to avoid having to reload the software via the CLI, as I have read elsewhere in this forum that it is cumbersome and prone to error...



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Steven Smith Wed, 07/22/2009 - 07:14

Can you restore the system to factory defaults, turn off the dashboard, then run the wizard.  Can you post the CCA logs after that?  I don't think that reloading the software would help fix the issue.

Steven DiStefano Wed, 07/22/2009 - 07:43

I just saw this myself last night.  The dashboard also wasnt retrieving CUE data on VOiceMail in my case.

Please check to see that CUE is Online.   Easy way is see if AA and voicemail respond to calls.

You can also check it via CLI:

This is a good result:

UC520#service-module integrated-Service-Engine 0/0 status
Service Module is Cisco Integrated-Service-Engine0/0
Service Module supports session via TTY line 2
Service Module is in Steady state
Service Module heartbeat-reset is enabled
Getting status from the Service Module, please wait..
Cisco Unity Express 7.0.3
CUE running on UC500

If its OFFLINE then session to it and type 'continue'

SBCS-Main#service-module integrated-Service-Engine 0/0 session
Trying, 2002 ... Open
User Access Verification

Username: cisco
Password: cisco

UC500-CUE(offline)# continue

If its in some other crazy state, you can 'reload' it.

jonathanlamm Wed, 07/22/2009 - 16:57

Thanks guys, but it seems that the problem is worse than this.  I cannot restore to factory defaults - when I try to do that, I get an error message that the CUE reset failed. The system seems to be stuck in a loop trying to load the CUE module, but it never completes.  I even tried totally wiping the compact flash last night and manually restoring the files using a compact flash card reader, as per the instructions in another post, but that still doesn't resolve the problem.  I'm going to contact my local Cisco support today as I think I need to replace the whole unit...

David Trad Wed, 07/22/2009 - 17:51

Hi Jonathan,

I'm going to contact my local Cisco support today as I think I need to replace the whole unit...

You wont need to do this, i can assure you it just does not happen to you, this happens to me quite often :(

The issue is in the way CCA is trying to communicate with the UC-500, it is really becoming a hit-n-miss thing and i have spat the dummy over this problem more then once, not at Cisco but at the fact i have still not been able to work around it quick enough.

Try the following:

  1. Switch of the UC-500 by unplugging it from the back
  2. Reboot your system, but before doing so turn all of all active NIC's including the wireless one and only have active the one that will be plugged into the UC-500 switch port.
  3. Turn off any FTP/TFTP Programms running in the background
  4. Make sure you have any and all exceptions in the windows firewall for CCA to work
  5. If you are using Windows Vista, XP and or Windows 7 right click on the CCA icon and run it as administrator or set this option to permanant in the properties section
  6. Once the UC-500 has reloaded, load CCA up (Version 2.0.1), as soon as it has finished its discovery process immediatly close the Dash Board make sure that is not running in the background, for some reason this has a part to play in some of the problems being experienced with the latest build of CCA and the previous production release.
  7. Do not run the Telephony WIzard just yet make sure nothing is running at all
  8. Go to maintanace >>> System upgrade, then proceed to click on the upgrade check box, if an error dialogue comes up advising that it has not finished loading up the voice information, then wait at maximum 2 minutes, if still no luck, then click the refresh icon up the top in the menues task bar.
  9. If the discovery process still had not completed or happened after clicking refresh try it one more time, if still not successfull close down CCA and then re-load it one more time
  10. Again follow the process from 1-7 making sure to close everything off as quickly as possible, if teh Dash Board starts to do Discovery it will most likely cause a lockup to the CUE (This is what i have discovered).

Follow those steps, yes i know it is a downright pain in the behind but we got to do what we got to do to get things to work.

When doing the upgrade, only do the IOS on its own, then do the CUE, i have now had 2 bad upgrades trying to do the complete update at once, but if i keep them seperate i have not had an issue yet.

If the CCA upgrade path fails, then obtain the 24.T IOS version, delete the one on the flash card at present and put the 24.T IOS on there and then reload the system, this will upgrade the IOS to the latest version, however keep in mind this upgrade method will not update any referrence points I.E your TFTP-SERVER reference points and others, however it will get the ball rolling.

I strongly recommend that you do the initial config with CCA before the IOS upgrade this way you can minimise disruption to the config, then after that is done do your CUE upgrade through CCA and any language file update as well.

Please let us know how you go with this.



jonathanlamm Wed, 07/22/2009 - 18:07


Many thanks for your time and quick response - will be trying this within the next hour and will let you know how it goes.

Best regards,


jonathanlamm Wed, 07/22/2009 - 20:05

Ok, thanks to David's advice above, I finally managed to get into the Upgrade Settings dialogue box, but now when I try to upgrade, whether I try IOS, CUE or All, I get an error message immediately, before it starts the upgrade as follows: Cannot retrieve CUE version information

David Trad Wed, 07/22/2009 - 20:11

Hi Jonathan,

before it starts the upgrade as follows: Cannot retrieve CUE version information

I get this one often these days, never did in previous versions, but im sad to say i am still stummped at this one as well :( i have no proven work around for this one at this stage, and i am unable to allways replicate it on the LAB system to re-produce it and then find the work around, it seems to happen when you least want it too.

What i suggest you do is check and make sure the CUE update file is not stil residing on the flash card from a previous attempt, if it is delete it, i dont know if that is what let me do the upgrade last, but it begun to work when i removed it of the flash card last time.

Also are you trying to upgrade to 3.2.1?



jonathanlamm Wed, 07/22/2009 - 20:21


I'm trying to upgrade to 7.0.3. Well, actually, I did that previously - I'm just trying to get this thing working properly again so that I can run the telephony setup wizard again and finish configuring it so that my client has a phone system!

For completeness, in response to Stephen's previous post: I cannot reset to factory defaults - I get the following error when I try: CUE Reset failed.

And in response to Steve's post, I checked via the CLI and the CUE is online - gives exactly the same output as your "good result".

David - I will now have a look on the CF card and see if that CUE update file is still there.  I take it you mean the .pkg file, right?


jonathanlamm Wed, 07/22/2009 - 20:29

Just checked the contents of the CF card.

There are two compressed files: CME-Phone-Loads-7.0.3 and CME-Support-Files-7.0.3 and three other files as follows:




David Trad Wed, 07/22/2009 - 20:46

Hi Jonathan,

I am going to assume that you can reset this thing back to factory defaults due to you attempt to do this previously.

Please do the following for me:

Download the UC500 7.1.0 files, extract from it the follwing:


Then download the latest IOS that i know has been very stable with me, and far fewer CCA problems


Copy both files to the Flash Card (Manually or TFTP) delete the old files, and then copy over to startup up the .cfg file (This will reset it to factory defaults)

Then reload the system.

Once this is completed, log into CCA and then do your CUE update.

I have had to do it this exact way now more then once just to get me out of trouble, there is no point sitting there stuffing around with it if you are pressed for time, the above for sure will work, may not be the best way and it might be the ugly way of doing things, IT JUST WORKS and that is more then enough for me to do it.

Hope it helps you out and you don't run into any further problems.



Message was edited by: David Trad

David Trad Wed, 07/22/2009 - 21:17

Hi Jonanthan,

7.1.1a will do just fine :)

And yes the command is correct as well.

I am having a brain freeze at the moment, not sure if you should "wri mem" after you copy the default config to startup, sorry about that i am just in the middle of burying my head in another botched Deployment and i am frustrated to no end :( ( Repairing someone elses mistakes blows, i hate it).

Good luck.



jonathanlamm Wed, 07/22/2009 - 23:57

Still no joy mate. It starts up with the new version, but when I try then to do the upgrade through CCA, I still get the error ""Cannot retrieve CUE Version Information".

I seem to have a big problem with CUE that is stopping me doing any restore to factory settings or software upgrades.

I also tried resetting the CUE through the CLI, as described in the process below, but when I execute Step 1, all I get is as per the attached screenshot - a never-ending loop...

To Reset CUE

Step 1: Session into CUE using the command service-module Integrated-Service-Engine 0/0 session. (Hit ‘enter’ twice to get a prompt).

Step 2: Type ‘offline’ to go into the offline mode.

Step 3: Type in ‘y’ when you are prompted with ‘Are you sure you want to go offline[n]?’

Step 4: Type in ‘restore factory default’

Step 5: Type in ‘y’ when you are prompted with ‘Do you wish to continue[n]?’

Step 6: Press the Enter key when prompted to ‘Press any key to reload:’

This reset can take 5-10 minutes. Wait until the CUE message ‘SYSTEM ONLINE’ is displayed before proceeding.

Step 7: Exit the CUE by typing ‘exit’.

David Trad Thu, 07/23/2009 - 02:06

Hi Jonathan,

I can really only say one thing MEH!!!!

I almost feel defeated, everything that has so far worked for me is not even coming close to working for you.

After a day like today i could throw out some nasty words that would get removed, but i have to say, these systems should not have these problems i can in a way now understand and appreciate why far too many companies are hesitant to move to a new IP-PBX and continue to renew their old key system contracts, after all why would you if it is going to give so much grief and require professional engineers to be on call all the time, their key systems just work.

I think you have tried everything that i would have, my final resort now would be to upgrade the CUE manually via CLI, this is a real pain and i try to avoid doing this, i will dig up my guide on how to do this (In laymans terms) and post them for you, i can not do it right now as i just got home and i have kids hanging of every ligiment wanting my attention (5 minutes of peace wouldnt go a stray.... Need to find my way to the beer fridge me thinks)

I can only encourage you to not give up, keep at it or otherwise if you get defeated once it just goes down hill from there, but i also caution you to err on the side of caution not to burn yourself out when tackling these problems, sometimes it pays to just leave it alone for a little while, work on another project and then come back to it, there is no point winding yourself in knots over it.

(PS) Can you try it from another PC by any chance?



Steven Smith Thu, 07/23/2009 - 06:56

From the PC with CCA on it, can you access the CUE gui (  Can you ping CUE?

jonathanlamm Mon, 07/27/2009 - 21:55

So, after a long call with Cisco TAC on Thursday evening, which included going back through everything I had tried previously (including restoring CUE through the command line interface, etc.), still with no success, the TAC support guy decided to implement an RMA and replace the hardware for me. All credit to Cisco, they sent a new unit from Singapore which was delivered to me in Hong Kong on Monday morning as promised.

So I started the configuration process again this morning on the new unit, starting with backing up the CF card and upgrading IOS and CUE using the 7.1.1ea package on the download site. This all went fine. I then ran the telephony setup wizard, which failed at 99% in the upload to the device, stating that no outgoing call plan was in place or words to that effect. This is a documented caveat, but really guys, it seems that the wizard fails much more often than it succeeds...

Anyway, most of the config seemed to have uploaded correctly, so at this point I abandoned the wizard and started configuring other stuff such as DID ports on my VIC3FXS/DID using the configuration menu in CCA.  Just by enabling the DID ports, I got incoming DDI working and routing to the correct extensions. However, I then needed to setup a particular instance for the main number on the DID range to route to a blast group. Here my problems started again - I keep getting exception errors when I try applying the changes.  The only solution I can think of is to reset to factory defaults and start the configuration again.  Thankfully I only have 7 handsets/users on the system!! It seems that you need to make a backup after every little change is made because the CCA, frankly, is so flaky that it could start refusing to cooperate at any point. CCA is a great idea (why should you need to use CLI these days, particularly for a small setup like this), and the UC520 is potentially a great little system, but I do wonder whether anyone in Cisco has actually ever tried using the CCA to configure it for a typical small business system setup. It is fraught with problems and you end up wasting an unbelievable amount of time troubleshooting and repeating things due to bugs. Judging from the posts on this forum, there are a lot of other people experiencing issues of a similar nature...

David Trad Mon, 07/27/2009 - 23:48

Hi Jonathan,

I am glad you got somewhere with Cisco TAC it is good to see that their TAC service level is allways as high as it usually is.

Here is my suggestion and it is one i have embraced since i comitted myself to continueing using CCA and working as hard as i can to see it grow be providing as much feed back as possible.

Use CCA for the intial provisioning of the system, the remaining work either use the Web UI or do as much as possible via the CLI, however if you are going to do CLI changes to the system, do your utmost best to stick by the OOB guide (Whilst not allways practical, try your best).

CCA to me still has many problems, i beleive this is the case because what might come across as successfull in a Lab Enviroment may not allways be reflected in the production enviroment, this is think has been proven many and countless times, however there are some that think i am a little cookoo for suggesting this (Non Cisco Staff i must add), however i am confident in my statement and i think the many troubles i have with it and others as well is evident that i am not far of the truth.

Right now CCA is a brilliant tool for getting the base code setup for CCA, the rest if find much quicker and easier doing it via the CLI and the Web UI, which by the way is well designed and works like a treat, never had a single problem with the Web UI.

I hope you sort the system out and are able to deliver it to the customer as a full working system, if you do need help with it you know you can allways e-mail me and i am happy to try and assist you.




This Discussion