what is the purpose of this command "spanning-tree vlan 10,92 cost 10"

Unanswered Question
Jul 22nd, 2009
User Badges:

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 92

switchport trunk allowed vlan 10,92

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

switchport trunk encapsulation dot1q

switchport trunk native vlan 92

switchport trunk allowed vlan 10,92

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

spanning-tree vlan 10,92 cost 10


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 07/22/2009 - 11:13
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,


>> spanning-tree vlan 10,92 cost 10


it modifies (increases) the STP cost for vlans 10 and 92 from default value to 10


These two vlans are also the only two vlans permitted on this L2 trunk.


Hope to help

Giuseppe


CCDECCDE9 Wed, 07/22/2009 - 11:24
User Badges:

if you see the config,both the interfaces have same config except this line...what does this mean ?

Giuseppe Larosa Wed, 07/22/2009 - 11:36
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,

that int gi0/1 the one without the STP cost command would be chosen as root bridge for vlans 10,92 if both links receive equal cost STP BPDU because cost to root bridge is calculated summing to cost in received BPDU the cost of the port where it is received.

So it is likely that G0/4 should act as backup path to root bridge.

if local switch is root bridge for vlans 10,92 there is no practical difference.


Hope to help

Giuseppe


Actions

This Discussion