routing in same router issue

Answered Question
Jul 23rd, 2009
User Badges:

dear friends

i have really big issue, i'm almost new to cisco hardware, usually i do good things in packet tracer so i got a 1841 and HWIC-4ESW.

i configured 192.168.1.1 on fa0/0 and 192.168.2.1 on fa0/1

when i ping from a computer connected to 1.1 to the interface fa0/0 and fa0/1 it is ok

but when i try to ping a computer in the other network, i get nothin

I check access-lists and every thing and i created the network in packet tracer and it works there.

please help me

i used the console to configure the router, and never used the CD came with the router, is there and relation??

and i saw that i have (logging buffered 51200 warnings) is this also a problem?

do i have to restore tha factory? and how to do this

please help me, otherwise i'll get troubles with my boss

Correct Answer by Richard Burts about 7 years 10 months ago

Yasser


I have looked at the config that you posted and I do not see any particular issues in it. I would guess that the issue might be that the PCs do not have the correct default gateway configured. Do the PCs connected to the network of FastEthernet 0/0 have 192.168.2.1 as their default gateway?


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Loading.
Peter Paluch Thu, 07/23/2009 - 11:16
User Badges:
  • Cisco Employee,

Hi,


If you have a brand new 1841 router, it is preconfigured with a certain starting configuration. I assume it can interfere with your changes you have done using console.


I suggest you simply erase the existing stored configuration (using the "erase startup-config" command) and reload the router. Then try to configure it again.


Also, if you try to ping a PC in another network, make sure that the PC is not using any kind of firewall and that its TCP/IP settings are OK.


About the CD - no, you do not need to use it at all.


Regards,

Peter


yasser_ja Thu, 07/23/2009 - 11:26
User Badges:

Thanks so much Mr.Peter

Actually, i can ping any PC using the router console or telnet session.

Only pinging from a PC is the problem.

here is it:




Attachment: 
glen.grant Thu, 07/23/2009 - 11:28
User Badges:
  • Purple, 4500 points or more

If you are pinging any other pc do you have the windows firewall turned off , it will block ping by default .

yasser_ja Thu, 07/23/2009 - 11:45
User Badges:

Actually, there is a symantec endpoint protection antivirus with firewall.

i can ping all computers using computers in same subnetwork.

But i also tried to access shares by typing computer ip in RUN in the XP but nothing happened.

Correct Answer
Richard Burts Thu, 07/23/2009 - 12:48
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Yasser


I have looked at the config that you posted and I do not see any particular issues in it. I would guess that the issue might be that the PCs do not have the correct default gateway configured. Do the PCs connected to the network of FastEthernet 0/0 have 192.168.2.1 as their default gateway?


HTH


Rick

yasser_ja Thu, 07/23/2009 - 12:54
User Badges:

Hi

This is my problem, every thing is fine as i studied and implemented in packet tracer.

Why i'm having this i don't know.

maybe i'll erase the config and start again, hope it works. If not, how do i check if the router came damaged to me or no problem in it? and what is this buffer warning?


Really really thanks for your time.

yasser_ja Fri, 07/24/2009 - 21:30
User Badges:

Please don't laugh at me OK.

I thing my problem is that i installed the router ok. After that i configured it OK. Then i configured my laptop. Then i used the cable comming to my office and i putted it in the router. and a made a cross over cable for my PC-Router.

After this all i tried to ping the router and it replys OK. The funny thing is that when i ping the computers on the other network and those computers has a gateway of 192.168.1.1, so this is the wornge right? i think that my problem is that i didn't change the gateway of computers to match the router's interface that connects to, becuase i'm lazy.

So, now i have another problem and it is:

the gateway 192.168.1.1 is our 3.5 G router E960 from Huwawi. we get internet through this router only because we are in site.

How to share internet connection since this huwawi router don't have a gateway?

Please i need to finish this issue.

Thanks for all.

shrikant2u Thu, 07/23/2009 - 13:43
User Badges:

Yasser ,


Per your notes fa0/0 = 192.168.1.1

and fa0/1 =192.168.2.1


However config you have posted shows


FastEthernet0/1 = 192.168.1.10 (?!?)

FastEthernet0/0 = 192.168.2.1



My guess is messed ip address.


GL

Shri


Richard Burts Thu, 07/23/2009 - 13:54
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Yasser


In your original post you say:"i saw that i have (logging buffered 51200 warnings) is this also a problem?". This is not a problem. This is fairly normal. This command controls the logging of messages to an internal buffer and sets the severity level to warnings. This is a normal behavior.


HTH


Rick


yasser_ja Thu, 07/23/2009 - 13:58
User Badges:

ooooohhhhhh

you are totally right about logging warnings.

"logging" i should to pay attention to that.

thank you very much.

please excuse me, i'm new and it will take some practice.

yasser_ja Thu, 07/23/2009 - 13:54
User Badges:

Sorry, i made little mistake.

Yes, the ips are

fa0/0: 192.168.2.1

fa0/1: 192.168.1.10

and the config in coputers are set along

with the interface that connects to.

Not a big issue.

The problem still than my router is not routing to onother network.

Like i said, every thing is perfect and the same router config i imported to packet tracer and it works. Maybe packet tracer is stupid or no capable of handling all commands.Or maybe i have a fualty router. Or maybe i have to erase and config again.

let us see on satarday.

If any one knows this issue, i'll be glad to hear suggestions.

Thank you all very much.

Again, what is this buffer warning? and how to remove it?

glen.grant Thu, 07/23/2009 - 16:23
User Badges:
  • Purple, 4500 points or more

You say this is a hwic 4 esw ? Is that where you are trying to run your subnet from . In the HWICS routed ports are not supported . You must create a layer 2 vlan in the vlan database and then create a corresponding layer 3 SVI for that vlan . you would then put the switchports into the correct vlan for the subnet . If you want 2 different subnets then you would have to create 2 layer 2 vlans in the vlan database and 2 layer 3 SVI's to support those vlans and then put the ports in the correct vlan. If you have put the address on the hwic port itself then that is not supported.

https://www.cisco.com/en/US/prod/collateral/routers/ps5853/prod_qas0900aecd8016c026_ps5854_Products_Q_and_A_Item.html

yasser_ja Thu, 07/23/2009 - 23:26
User Badges:

No my dear, i'm not using the HWIC at all and i removed it also.

Fine now, is there any way to check the packets are being moved inside the router?

I mean to monitor wether the router is routing the packets correctely or not.

scollins34 Sat, 07/25/2009 - 06:30
User Badges:

You must add a route to your Huwawi router stating finding the 192.168.2.0 /24 gateway to use is the 192.168.1.10. You have to routers in place and both routers need to know about the other. I would use rip v2


Cisco 2811

router rip

version 2

network 192.168.2.0

network 192.168.1.0


Huwawi

router rip

version 2

network 192.168.1.0

network internet access

yasser_ja Sat, 07/25/2009 - 21:52
User Badges:

Thanks, I think it is my mistake.

E960 router is a 3.5G only for internet access. No configurations exept in CGI by internet browser.

I tried to telnet it, but something like BUSYBOX or BESYBOX (I can't remmember) is comming. I don't know what is this.

By searching online I think that I need to configure NAT.

Is it true that NAT is my solution?

yasser_ja Sat, 07/25/2009 - 23:29
User Badges:

OK, finally i can ping my router using a PC in another network.

but why i can't ping websites and can't access internet???

When ip ping a website, i get the ip of it but i get no reply.

Note: our internet is a 3.5G via our mobile Provider in UAE in Dubai.

And we don't have a real IP or a Fix one. GOT IT???

How to fix my last issue. Please help, i'm almost understand everything



Attachment: 
yasser_ja Sat, 07/25/2009 - 23:51
User Badges:

Guys

Congratulations.............^_^

Finally I got what I want.

My final mistake is that i'm pinging hotmail.com then I got 192.168.2.1 (fa0/0) my computer connected to.

So I added (ip route 0.0.0.0 0.0.0.0 192.168.1.1).

After that got destination unreachable.

Then I thought maybe the LAN MAC filter in our 3.5g router has something to do with this.

So I turned the firewall of the 3.5g router off.

But I still getting destination unreachable.

But when I pinged yahoo.com it really worked.

It seems that stupid hotmail don't allow ICMP.


But at least I got what I want, and i understanded it very well.

Hope to see you guys and the best to you all.

jimmysands73_2 Sun, 07/26/2009 - 21:56
User Badges:
  • Silver, 250 points or more

Glad to hear. Remember you can not always use ping'g by DNS name as a troubleshooting technique. Most times its fine, but everynow and then it bites you. When in doubt, I ping Earthlinks DNS server at 207.217.120.83.

Actions

This Discussion