Changing logo and background image on Cisco sets

Unanswered Question
Jul 24th, 2009

Is there someone that can help me how to change the logo for the 7911, CP521, CP525 and 7941.

I saw some docs on the net and tried to change on the 7941 with no luck.

I created a directory and put the images there:

Directory of flash:/Desktops/320x196x4/

  356  -rw-         167  Jul 24 2009 14:14:36 +01:00  List.xml
  357  -rw-       39870  Jul 24 2009 14:08:14 +01:00  FullDecsis2.png
  358  -rw-        3365  Jul 24 2009 14:09:04 +01:00  TN-Decsis2.png

On the List.xml I put:

<CiscoIPPhoneImageList>

<ImageItem Image="flash:/Desktops/320x196x4/TN-Decsis2.png"
URL="flash:/Desktops/320x196x4/FullDecsis2.png"/>

</CiscoIPPhoneImageList>

I open the debug - debug tftp events - and when I press the background image I saw this message:

000468: Jul 24 13:29:06.653: TFTP: Looking for Desktops/320x196x4/List.xml

But don't see the image on the screen.

I made the images with:

Use an image manipulation program of your choice to create two Portable Network Graphics (PNG) files for each image:

  • Full size image—320 pixels (width) by 212 pixels (height)

  • Thumbnail image—80 pixels (width) by 53 pixels (height)

Can someone helpe me on how to do it?

Best Regards,

Jose Carlos Silva

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jose Carlos Silva Mon, 07/27/2009 - 07:17

Thanks guys for your replay.

Hi Marcus, yes I read the thread but did not succeeded in put the image on the set.

I will try again and see whats happening.

Thanks one more for the replay - Marcus and Steve.

Best Regards,

Jose Carlos Silva

Jose Carlos Silva Tue, 07/28/2009 - 03:01

Hi all, until now I do not succeed to put the images on my set 7941.

I follow step by step the Steve doc but no luck.

When I go to Settings à User Preferences à Background Images I saw on the console the set trying to read the List.xml as below but no images.

000146: Jul 28 09:29:10.663: TFTP: Looking for Desktops/320x196x4/List.xml

The files are there:

122          0 Jul 24 2009 12:32:16 +01:00 Desktops/320x196x4
123        651 Jul 28 2009 09:52:04 +01:00 Desktops/320x196x4/List.xml
124      39870 Jul 24 2009 14:08:14 +01:00 Desktops/320x196x4/FullDecsis2.png
125       3365 Jul 24 2009 14:09:04 +01:00 Desktops/320x196x4/TN-Decsis2.png
126     138278 Jul 27 2009 15:31:28 +01:00 Desktops/320x196x4/Fountain.png
127       7953 Jul 27 2009 15:32:18 +01:00 Desktops/320x196x4/TN-Fountain.png

I even put the default List.xml and even so I can't see the system default images.

99           0 Jul 8 2009 18:35:08 +01:00 Desktops
100     131470 Jul 8 2009 18:35:10 +01:00 Desktops/CampusNight.png
101      80565 Jul 8 2009 18:35:10 +01:00 Desktops/CiscoFountain.png
102       8156 Jul 24 2009 11:50:22 +01:00 Desktops/CiscoLogo.png
103     138278 Jul 8 2009 18:35:12 +01:00 Desktops/Fountain.png
104     109076 Jul 8 2009 18:35:14 +01:00 Desktops/MorroRock.png
105     108087 Jul 8 2009 18:35:14 +01:00 Desktops/NantucketFlowers.png
106      10820 Jul 8 2009 18:35:16 +01:00 Desktops/TN-CampusNight.png
107       9657 Jul 8 2009 18:35:16 +01:00 Desktops/TN-CiscoFountain.png
108       2089 Jul 24 2009 11:49:42 +01:00 Desktops/TN-CiscoLogo.png
109       7953 Jul 8 2009 18:35:16 +01:00 Desktops/TN-Fountain.png
110       7274 Jul 8 2009 18:35:18 +01:00 Desktops/TN-MorroRock.png
111       9933 Jul 8 2009 18:35:18 +01:00 Desktops/TN-NantucketFlowers.png

What I'm doing wrong?

My UC520W is with rls 7.0.3.

Can anyone give me a tip? In attach I'm sending the list.xml - default one - and the files I created.

Best Regards,

Jose Carlos Silva

Attachment: 
Eivind Jonassen Tue, 07/28/2009 - 05:10

Jose,

Are you sure that you have the tftp-server correct in your running config???

Do the following;

UC_box# sh run | i 320x196x4/List.xml

If you don't get a result from this command you have to add the tftp-server commands to your config.

Regards

Eivind

Steven DiStefano Tue, 07/28/2009 - 05:50

Jose,

I now have a 7941 with the background = "decsisII groupo decsis"

Here is what I did (using my document).

I edited List.xml with notepad on my PC and added this:

URL="flash:/Desktops/320x196x4/FullDecsis2.png"/>

Then I tftp'ed that file to flash:

SBCS-Main#copy tftp flash:
Address or name of remote host [192.168.10.17]?
Source filename [List.xml]?
Destination filename [/Desktops/320x196x4/List.xml]?
%Warning:There is a file already existing with this name
Do you want to over write? [confirm]
Accessing tftp://192.168.10.17/List.xml...
Loading List.xml from 192.168.10.17 (via BVI1): !
[OK - 857 bytes]

Then I TFTPed both pngs to the same directory:

SBCS-Main#copy tftp flash:
Address or name of remote host [192.168.10.17]?
Source filename [List.xml]? TN-Decsis2.png 
Destination filename [/Desktops/320x196x4/TN-Decsis2.png]?
Accessing tftp://192.168.10.17/TN-Decsis2.png...
Loading TN-Decsis2.png from 192.168.10.17 (via BVI1): !
[OK - 3365 bytes]

3365 bytes copied in 0.648 secs (5193 bytes/sec)

SBCS-Main#copy tftp flash:
Address or name of remote host [192.168.10.17]?
Source filename [TN-Decsis2.png]? FullDecsis2.png
Destination filename [/Desktops/320x196x4/FullDecsis2.png]?
Accessing tftp://192.168.10.17/FullDecsis2.png...
Loading FullDecsis2.png from 192.168.10.17 (via BVI1): !
[OK - 39870 bytes]

39870 bytes copied in 1.112 secs (35854 bytes/sec)

Then I adjusted the TFTP-Server CLI on my machine to find both pngs and to find List.xml:

tftp-server flash:/Desktops/320x196x4/List.xml alias Desktops/320x196x4/List.xml
tftp-server flash:/Desktops/320x196x4/TN-Decsis2.png
tftp-server flash:/Desktops/320x196x4/FullDecsis2.png

Then I uded the 7941 phone GUI to select it:

TFTP-SERVER Debug:

002151: TFTP: Looking for Desktops/320x196x4/List.xml
002152: TFTP: Opened flash:/Desktops/320x196x4/List.xml, fd 10, size 857 for process 172
002153: TFTP: Finished flash:/Desktops/320x196x4/List.xml, time 00:00:00 for process 172
002175: TFTP: Looking for /Desktops/320x196x4/TN-Decsis2.png
002176: TFTP: Opened flash:/Desktops/320x196x4/TN-Decsis2.png, fd 10, size 3365 for process 172
002177: TFTP: Finished flash:/Desktops/320x196x4/TN-Decsis2.png, time 00:00:00 for process 172
002178: TFTP: Looking for /Desktops/320x196x4/FullDecsis2.png
002179: TFTP: Opened flash:/Desktops/320x196x4/FullDecsis2.png, fd 10, size 39870 for process 172
002180: TFTP: Finished flash:/Desktops/320x196x4/FullDecsis2.png, time 00:00:00 for process 172

And its there.

The List.xml file you attached didnt have the png files in it I noticed.   Do the above and you should be gold.

Steve D.

mondakota Tue, 08/03/2010 - 08:53

Oh Thanks for that. All guides never include update TFTP server configuration.

Leo

Jose Carlos Silva Tue, 07/28/2009 - 08:19

oops :( miss the TFTP.

Sorry Steve, but did not understood the item 4 of your manual.

Works fine, just need to adjust the image because it stays with dark areas on the top and below the logo.

Thanks very much for the help all of you have given to me.

Best Regards,

Jose Carlos Silva

Actions

This Discussion