ASDM dies on new Vista laptop

Unanswered Question
Jul 24th, 2009
User Badges:

I have a new laptop, Lenovo T400 with Vista Business ed, SP1 installed. ASDM will not run on this laptop: Every time it just dies/disappears right after I log in. I tried different versions ASDM, different ASAs. I knew from earlier experience that there's a problem with Java 1.6u11 so I installed u7. I also tried u6 and u12. Everytime the same result: Immediately after logging into ASDM the application dies. Other Java apps run fine.

Is there anybody that can point me in the right direction, how I can trace what's going on? I hate to be confined to the CLI....

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
PETER EIJSBERG Mon, 07/27/2009 - 08:31
User Badges:

Thanks, tried it, removed all, disabled Java plugin on FF, and reinstalled version 7. Now ASDM works on a ASA running 7, but still not on ASAs running version 8...

robertson.michael Mon, 07/27/2009 - 09:48
User Badges:
  • Silver, 250 points or more

Hi Peter,


What version of ASDM are you running on the 8.x ASAs?


I would suggest trying a packet capture to see where in the conversation the traffic is failing. You could also try enabling 'debug http' to see if that gives you any insight into the problem.


'debug http' Command Reference:

http://www.cisco.com/en/US/docs/security/asa/asa80/command/reference/d1.html#wp1997777


Hope that helps.


-Mike

PETER EIJSBERG Fri, 08/07/2009 - 10:54
User Badges:

OK, I finally figured it out - it was a rights problem in Vista. Removed Java, installed again as Administrator (which is apparently not the same as running the install script as user and elevating rights), and now it works

PETER EIJSBERG Thu, 11/05/2009 - 16:54
User Badges:

New laptop, Windows 7, and immediately the same problems - ASDM not working, not with latest Java, not with 6.7. Finally fixed it using info from CSCsw43498 and setting compatibility mode to XPSP3

Actions

This Discussion