Support for Cos per access on 7206 as PE

Unanswered Question
Jul 25th, 2009

We are exploring the possibility of configuring QOS policies for the main interface, which has multiple sub-interfaces. I want to know if a common policy applied on the main interface will be applicable to the subinterfaces too. This makes all layer 2 connections under the interface subject to the QoS policy. Each class within the policy will operate on the aggregate class traffic across all the layer 2 connections. If the Qos policy is at the full interface rate then a single tier policy can be applied directly to the main interface. If the required speed is less than the interface then a hierarchical policy can be applied. In the output direction and parent policy and a child policy are constructed. The child policy matched on each of the Qos classed and provided the necessary treatment. The parent policy is applied to the main interface. IT matched on the default class (i.e. all traffic), applied a shaper to limit the output bandwidth and also is where the child policy is applied. In the inbound direction the same structure is repeated except in this case the parent policy used a policer rather than a shaper.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Laurent Aubert Sun, 07/26/2009 - 11:49

Hi,

Applying a service-policy on the main interface provides a shared QoS policy for all the subinterfaces. If you have a class for IPP 5 for example, all the IPP 5 traffic send over all the subinterfaces will be in the same queue.

HTH

Laurent.

adarsh Tue, 07/28/2009 - 17:29

Thanks! Laurent for your response, however things are still unclear to me. Let me elaborate it in context of my original post. Not sure if the following configs (for policy and interface) is supported on Cisco platform (7200 preferably):

-----------------------------------------

Given below is the sample of policy and interface config:

POLICY CONFIG:

class-map nni_mgmt_input

match access-group 122

!

class-map match-any nni_ef_input

match ip prec 5

!

class-map match-any nni_af4_input

match ip prec 3

!

class-map match-any nni_ef_output

match qos-group 4

!

class-map match-any nni_af_output

match qos-group 6

match access-group 124

match access-group 123

!

policy-map NNI-IN-test

description CPA policy map to apply to main NNI interface inbound with remarking

class nni_mgmt_input

police 8000 8000 8000 conform-action set-mpls-exp-transmit 6 exceed-action set-mpls-exp-transmit 6

!

class nni_ef_input

set ip dscp ef

police 2600000 8000 8000 conform-action set-mpls-exp-transmit 4 exceed-action drop

!

class nni_af4_input

set ip dscp af41

police 8000 8000 8000 conform-action set-mpls-exp-transmit 6 exceed-action set-mpls-exp-transmit 6

!

class class-default

set ip dscp 0

police 8000 8000 8000 conform-action set-mpls-exp-transmit 5 exceed-action set-mpls-exp-transmit 5

!

policy-map NNI-PIN-test

class class-default

police 20416000 81600 163200 conform-action transmit exceed-action drop

service-policy NNI-IN-test

!

policy-map NNI-OUT-test

description Outbound CPA child policy for NNI gateway

class nni_ef_output

police 2600000 8000 8000 conform-action set-dscp-transmit 40 exceed-action drop

priority 2600 8000

!

class nni_af_output

bandwidth 3568

police 8000 8000 8000 conform-action set-dscp-transmit 24 exceed-action set-dscp-transmit 24

random-detect dscp-based

random-detect exponential-weighting-constant 10

random-detect dscp 24 141 226 10

!

class class-default

bandwidth 13432

police 8000 8000 8000 conform-action set-dscp-transmit 8 exceed-action set-dscp-transmit 8

random-detect dscp-based

random-detect exponential-weighting-constant 9

random-detect dscp 8 70 186 5

!

policy-map NNI-POUT-test

class class-default

shape average 20400000 81600

service-policy NNI-OUT-test

-----------------------------------------

INTERFACE CONFIG

interface GigabitEthernet0/1

dampening

no ip address

load-interval 30

media-type rj45

speed 1000

duplex full

no negotiation auto

no cdp enable

no clns route-cache

service-policy input NNI-PIN-test

service-policy output NNI-POUT-test

!

interface GigabitEthernet0/1.2

encapsulation dot1Q 2

ip vrf forwarding vrfCPPCtesting2

ip address x.x.x.x

no cdp enable

!

interface GigabitEthernet0/1.3

encapsulation dot1Q 3

ip vrf forwarding vrfCPPCtesting3

ip address x.x.x.x

no cdp enable

!

interface GigabitEthernet0/1.4

encapsulation dot1Q 4

ip vrf forwarding vrfCPPCtesting4

ip address x.x.x.x

no cdp enable

!

interface GigabitEthernet0/1.5

encapsulation dot1Q 5

ip vrf forwarding vrfCPPCtesting5

ip address x.x.x.x

no cdp enable

!

Laurent Aubert Wed, 07/29/2009 - 07:07

Hi,

I don't see any issue so next step is to test it may be with the last release to have the latest QoS feature ;-)

Laurent.

adarsh Wed, 07/29/2009 - 15:32

Thanks! Laurent.

I referred a link on "heirarchial QOS config" which you posted for someone's query in the same forum. Shall let you know if i have any/few queries.

Thanks!

adarsh Wed, 07/29/2009 - 15:43

Thanks! for your reply Laurent,

Here's the briefing on tests and few queries in the end, see if you can spare few minutes to clarify.

•The main physical interface is policed at 20Mbps with the class default in the parent policy map.

•Child policy is configured in the main physical interface.

•No policies are applied in the sub interfaces. Different VRFs corresponding to different customers are configured on each of the sub interfaces. Same IP addresses are assigned for all the sub interfaces for the testing.

•The child policy in the main interface has 4 classes defined and each class is policed to 5Mbps which different actions defined for in contract and out of contract traffic. The config is below:

R#sh policy-map interface gig0/3

GigabitEthernet0/3

Service-policy input: NNI-PIN-test

Class-map: class-default (match-any)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: any

0 packets, 0 bytes

30 second rate 0 bps

police:

cir 20000000 bps, bc 625000 bytes

conformed 0 packets, 0 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps

Service-policy : NNI-IN-test

Class-map: EXP5 (match-all)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip dscp ef (46)

police:

cir 5000000 bps, bc 156250 bytes

conformed 0 packets, 0 bytes; actions:

set-mpls-exp-transmit 5

exceeded 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps

Class-map: PREC4 (match-all)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip precedence 4

police:

cir 5000000 bps, bc 156250 bytes

conformed 0 packets, 0 bytes; actions:

set-mpls-exp-transmit 4

exceeded 0 packets, 0 bytes; actions:

set-mpls-exp-transmit 3

conformed 0 bps, exceed 0 bps

Class-map: PREC2 (match-all)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip precedence 2

police:

cir 5000000 bps, bc 156250 bytes

conformed 0 packets, 0 bytes; actions:

set-mpls-exp-transmit 2

exceeded 0 packets, 0 bytes; actions:

set-mpls-exp-transmit 1

conformed 0 bps, exceed 0 bps

Class-map: PREC0 (match-all)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: ip precedence 0

police:

cir 5000000 bps, bc 156250 bytes

conformed 0 packets, 0 bytes; actions:

set-mpls-exp-transmit 0

exceeded 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps

Class-map: class-default (match-any)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: any

0 packets, 0 bytes

30 second rate 0 bps

Have attached the config and shall be putting in next post as well to make things handy.

Queries:

•Will the total BW for all 'ef' marked packets from all the subinterfaces be policed to 5 Mbps or is it per subinterface?

•In either case, how do I see the BW consumption for each subinterface?

•How do I verify intercos bursting in this case?

Regards

Attachment: 
adarsh Wed, 07/29/2009 - 15:45

Hi Laurent,

As mentioned in previous post here's the config (same as per the attachment uploaded earlier) from the interfaces in question:

R#sh run int gig0/3.2

Building configuration...

Current configuration : 153 bytes

!

interface GigabitEthernet0/3.2

encapsulation dot1Q 2

ip vrf forwarding VRF1

ip address 10.1.1.1 255.255.255.252

end

R#sh run int gig0/3.3

Building configuration...

Current configuration : 153 bytes

!

interface GigabitEthernet0/3.3

encapsulation dot1Q 3

ip vrf forwarding VRF2

ip address 10.1.1.1 255.255.255.252

end

R#sh run int gig0/3.4

Building configuration...

Current configuration : 153 bytes

!

interface GigabitEthernet0/3.4

encapsulation dot1Q 4

ip vrf forwarding VRF3

ip address 10.1.1.1 255.255.255.252

end

R#

Laurent Aubert Wed, 07/29/2009 - 16:27

Hi,

•Will the total BW for all 'ef' marked packets from all the subinterfaces be policed to 5 Mbps or is it per subinterface?

A: Total Bw will be policed to 5 Mbps.

•In either case, how do I see the BW consumption for each subinterface?

A: you can't as the classes are common to all VLANs.

•How do I verify intercos bursting in this case?

A: Not sure to understand what you mean here..

Laurent.

Actions

This Discussion