SPA962 and Inbound Caller ID anonymous problem

Unanswered Question

I have been using the SPA series of phones for a while and find them extremely flexible and a good value. Most of the problems i have encountered prior have been fixed through firmware upgrades. I am hoping I am just missing something obvious here with my current problem.

I have set an SPA962 with the 932 sidecar for a reception environment. The receptionist receives calls for a group of companies (one phone system). In order to help the recepionist identify for which company the call is for we prefix the name of the company  in the Caller ID. eg.

Caller for Company A

incoming call will display:


A:John Smith

^_________________identifies the company the intended call is for

This work great except for Anonymous callers. If the caller id number is "anonymous" it displays:



It does not display the caller id name portion

I think it should display the following:



This would allow the receptionist to Answer the call acordingly. Any help is appreciated. Thank you,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Glenn Quesenberry Tue, 07/28/2009 - 06:21

Nick,  Have you tried the "Caller ID Map" configuration from the SPA9X2 Configuration Guide (click here)?  Page 165 of the guide discusses out to configure this on the SPA9X2 phones.  Not know what platform you are running this phone & sidecar on, I have no idea where you could check the configuration from that side.  Is this on a SPA9000 or a 3rd Party system?



Hi Glenn,

Thanks for the suggestion. I actually did look at the Caller ID MAP feature. This will not work because it only deals with the caller id "number". The caller id number is always "anonymous". This would work if I can change the caller id "number" based on a condition of the caller id "name"

Just to note that everything works with regular caller id, its only anonymous that is a problem.

I am using an audiocodes MP-118 FXO gateway for PSNT <>VOIP in SIP mode. The SIP server is Asterisk 1.4.x, I can provide more details if needed.

From the Asterisk CLI and CDR's I can see that Asterisk is passing the correct information.

What I will do next time I have the chance is test this with a soft phone and another vendor SIP phone to rule out possible issues anywhere else.

The reason I beleive its the phone is because it displays "Anonymous Caller"

I don't see where it is getting "Caller" as it is not part of the Caller ID name anywhere. It seems the phone is displaying "Anonymous Caller" based on just checking the caller id "number" and not displaying what is fully provided.

Alberto Montilla Tue, 07/28/2009 - 08:25

Dear Sir;

Can you please if possible send the traces of a normal and an anonymous call where Asterisk is sending the (modified) invite message? If you are properly modifying the caller ID name on the from header, then please modify the [SIP] Caller ID Header: to FROM. This should make the deal.


Before I start making changes to Asterisk or the gateway I need to make sure that this is not an SPA962 bug or setting on the phone.

What you are suggesting is fine in a test environment but I really don't want change anything I don't have to on clients system that has been working great minus this anonymous caller id issue.

What I have done tonight is test the anonymous caller id with 2 soft phones.

Both phones displayed the anonymous caller id correctly. They displayed "anonymous" for the caller id number. And they displayed "A:anonymous" for the caller id name. The "A:' is what we prefix to the caller id name.

I used Ekiga on Linux client (ubuntu) for one test. And xlite 3.0 beta on Windows Vista for the other test.

Both displayed the called id as expected.

I will test with 3 other hardware vendor SIP phones. If the anonymous caller is handled correctly with those phones it has to be a setting or a bug in the SPA962.

I will post my findings in a few days.

Alberto Montilla Wed, 07/29/2009 - 06:35

Hi Nick;

Please see my latest response. I'm asking for a small change on the phone configuration to try out. Don't change anything in asterisk.


Hi Alberto,

I've made the required changes on SPA962 but nothing has changed with "Anonymous Caller" being displayed. It looks like this is a hard coded feature of the SPA phones. I also tried an SPA942 with the same results.

I was hoping that someone else in the community would be using a similar setup and encoutering the same issue. Is there a different way of tackling this problem. Can I submit a bug report and have an engeineer review and see if the problem can be created in a lab environement?

Hi Alberto,

I was able to test my setup today with 2 other vendor SIP phones. Both phones displayed the anonymous caller id "name" correctly. For me this narrows down the problem to a phone issue instead of a phone system issue.

I will get you the information you requested before. I will post the sip debug log (with and without anonymous) for you once I get another chance to get in this particular office.

Hi Alberto,

Sorry for the long delay in getting the log information for you.

I was able to figure an asterisk work arround that might allow to actually determine where the problem is.

I have attached 3 files:

1. Regular call - did not block the caller id - everything works as expected - does display our caller id name prefix

2. Anonymous call - blocked caller id - caller id on phone displays "Anonymous Caller" - Does not display our Caller id name prefix

3. Anonymous call but changing the caller id name to "Unknown" before it hits the SPA962. Does display our Caller id name prefix

   This should allow you to figure out that it's actually the phone that is the problem since I am not changing any invites or privacy flags comming from the gateway. 

Alberto Montilla Mon, 08/31/2009 - 06:03

Hi Nick;

Could you please filter out the third trace. There are multiple calls, so not sure which one is the one having the behavior. In addition, please capture the Phone debug info. This will help us to clarify the issue as well.

Instructions to obtain the device debug/syslog info here: /docs/DOC-9934


Hi Harry,

In your trunk settings you need to change your context line to:


edit the following file:


Insert the following code:


include => mycaller-id-change

include => from-trunk


exten => _X.,1,Execif($[${CALLERID(num)}=anonymous]|Set|CALLERID(all)="Unknown <1234567890>")

exten => _X.,n,NoOp(Changed caller id to ${CALLERDID})


This Discussion

Related Content