Router on stick DHCP issue

Unanswered Question
Jul 27th, 2009

Hello All,

I have 3750 cores that handle L3 traffic for the vlans. These 3750 connect to another 7200 which is used to inter -site traffic. Now since I ran into an SVI counter limitation on the c3750, I wanted to monitor traffic on a vlan 6 some how. I thought of taking this vlan alone to a router on stick config.

* I chose a spare interface on 7200 config is with IP address 10.X.6.1 /24 ( for vlan)

* connected this int of 7200 to one of the cores ( configured that switchport as access vlan 6 )so that the 7200 interface will belong to same broadcast domain.

* shut the layer 3 inteface for the vlan 6 on the cores.

* now I was confident about this behaviour, until i discovered the dhcp was nt working(especially new releases, renewal releases where working fine)

* i added the ip helper command to the 7200 interface, But still broken.

Am I missing something here?

I can ping the dhcp servers from the 7200 though?

please help

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Endwigast Mon, 07/27/2009 - 05:22


- what is the ip address of the layer 3 interface on the cores?

- can the pc ping the servers?

- what is the gateway ip address configured on the pc's on vlan 6?

prakadeesh Mon, 07/27/2009 - 06:00

the cores were having line 10.x.6.1 as the hsrp address for this vlan. i have moved this ip to the 7200 interface and shut this in the cores(3750). I am trying to get a dhcp address on the machines but thats not working. So there is no default gateway nor the PC will be able to ping anywhere as DHCP is failing...

* my impression was that the dhcp discover travels through LAN. Hits the core. Now since the 7200 is hanging of a switchport access vlan 6 this should be able to get the DHCP broadcast. hence the iphelper in that interface should be able to help with this DHCP. But Its not working. not sure Y. But incase I assign a manual IP to the machine the machine can ping the gateways and beyond.

Endwigast Mon, 07/27/2009 - 06:18

forgot to tell you. you should configure subinterface on 7200 with dot1q vlan 6 and then configure the switch port connecting to the 7200 as trunk port.

something like this

interface FastEthernet0/1.6

encapsulation dot1Q 6

ip address 10.x.6.1

ip helper-address x.x.x.x

switch port connecting to the 7200 should be trunk port

assign a static ip on the pc and try to configure the dhcp server if you can't ping the server then there is something wrong on the layer 3

prakadeesh Mon, 07/27/2009 - 06:36

what i have done is like


int fa0/0

ip add 10.x.6.1/24

ip helper-add


int fa0/0

switchport access vlan 6

now with this config itself if i assign the pc with 10.x.6.22/24 and default gateway as 10.x.6.1/24 i can ping all the servers.

so IMHO nothing seems to be wrong with L3, something is messing up DHCP :(

Endwigast Mon, 07/27/2009 - 06:41

nothing is wrong with the dhcp. the way you configured the 7200 is what's the issue

do below on your 7200 and switch. replace with ip address you used


interface FastEthernet0/1.6

encapsulation dot1Q 6

ip address 10.x.6.1

ip helper-address x.x.x.x


int fa0/0

switchport mode trunk


This Discussion