Problems with FXS disconnect

Unanswered Question
Jul 27th, 2009
User Badges:

Hi,


I have 186x series router with build-in four FXS ports. When I call FXS port (SCCP IP Phone through H.323), I get connected to GSM GW; when I disconnect by IPPhone the line is still busy


Config:


!

voice-port 0/0/3

no supervisory disconnect lcfo

no battery-reversal

signal groundStart

input gain 6

compand-type a-law

no comfort-noise

cptone PL


!

!

dial-peer voice 600 pots

max-conn 1

destination-pattern 0048.........

port 0/0/3

forward-digits all

!



Ani ideas how to say to GSM GW that call is cleared?


Best Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 07/27/2009 - 14:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

To begin with, should be signal loopstart.


Then check GSM box documentation for what disconnect supervision method it can use.


Note these connection are better done with ISDN BRI or SIP. Analog is always source of trouble.



m.laskowski Mon, 07/27/2009 - 23:35
User Badges:

I tried loopstart earlier and the problem still exists


It's a Nokia GSM adapter - the default rule for disconnect supervision in this adapter is monotoring silence. Any idea how to apply such settings on Cisco router ?


Best Regards

Paolo Bevilacqua Tue, 07/28/2009 - 07:35
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Silence is silence, no special config is required.


I have a client with old Nokia adapters and they work acceptably. They are of the type with both FXS and FXO ports.

m.laskowski Wed, 07/29/2009 - 00:06
User Badges:

It is old Nokia adapter - can You paste part of config ? (I'm interested in voice-port part) Thanks

Actions

This Discussion