Mgcp fax relay problem

Answered Question
Jul 28th, 2009

Hy guys,

As I can see a lot of people have problems with mgcp fax relay unfortunately none of the suggeted configs helped till now.

I have a CM 7 , 2x3845 12.4(24)T, 2xVg224 12.4(24)T. The gateways are registered in CM as MGCP.

My current config looks like this:

ccm-manager redundant-host 10.xx.xx.x 10.xx.x.x

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.xx.xx.x 10.xx.xx.x

ccm-manager config

!

mgcp

mgcp call-agent 10.xx.xx.x 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode cisco

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

mgcp default-package fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax rate 14400

mgcp fax t38 ecm

mgcp fax-relay ans-disable

Thank you for your help.

Attachment: 
I have this problem too.
0 votes
Correct Answer by Nicholas Matthews about 7 years 4 months ago

Hi,

Normally the 'latest and greatest' is a good idea. The problem is sometimes there are new bugs in those versions that are not fixed yet. This is one of those cases.

I would download 12.4(15)T9 onto your MGCP gateway and try this again. The configuration looks correct.

Also, please check 'show controller t1' (or e1) and check for slips. If you have slips you have likely forgotten to use the 'network-clock-select 1 t1 0/0/0' command. If you have slips and that command present, you may have a wiring/provider issue.

hth,

nick

Correct Answer by Nicholas Matthews about 7 years 4 months ago

Hi,

You may be hitting a known defect that is pretty popular at the moment: CSCsy29533

It causes MGCP T38 fax to not work on certain versions. I would downgrade IOS to 12.4(15)T9 to avoid this problem.

hth,

nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.

Hi Ron,

Here is the Fax Machine settings you asked for:

Also please set Fax machine settings:

- working as a G3 machine and not super G3

- Disable the Error Correcting Mode (ECM)

- fax speed to 9600 bps

Please let me know if this helps?

Test:

- Make test call from Fax Machine to internal extension (Cisco IP Phone)

+ On Cisco IP Phone press the "?" twice, look at call quality and Codec.

Send me the information.

If you dont get a dial tone, change to Callig Search Space to Unrestricted and restart/Reset the port.

Test and let me know...

Many Thanks,

Nico Kotze

Correct Answer
Nicholas Matthews Tue, 07/28/2009 - 04:44

Hi,

You may be hitting a known defect that is pretty popular at the moment: CSCsy29533

It causes MGCP T38 fax to not work on certain versions. I would downgrade IOS to 12.4(15)T9 to avoid this problem.

hth,

nick

ronin2k8cronus Tue, 07/28/2009 - 05:09

Sry Nico,

i don't really undersatnd what do you mean by "I always use the latest like you doing at the moment as above logic only apply up to a certain level and not above." Can you please explain?

Should i downgrade on the VG's and the routers?

Update CUCM:

UCSInstall_UCOS_7.0.2.21900-10.sgn.iso_part1of2

Release Date: 15/Jun/2009

Upgrade 2845: Note:- always make sure you have enough memory and the Flash is big enough everything ou upgrade a IOS.

SP SERVICES

c3845-spservicesk9-mz.124-24.T1.bin

Release Date: 23/Jun/2009

Size: 52291.83 KB (53546832 bytes)

Minimum Memory: DRAM:256 MB Flash:64 MB

ronin2k8cronus Tue, 07/28/2009 - 05:15

R-VOCE-E7-SPLAI# sh inv

NAME: "3845 chassis", DESCR: "3845 chassis"

PID: CISCO3845

NAME: "c3845 Motherboard with Gigabit Ethernet on Slot 0", DESCR: "c3845 Motherboard with Gigabit Ethernet"

PID: CISCO3845-MB , VID: V07 ,

NAME: "2nd generation four port FXO voice interface daughtercard on Slot 0 SubSlot 0", DESCR: "2nd generation four port FXO voice interface daughtercard"

PID: VIC2-4FXO , VID: V03 ,

NAME: "2nd generation four port FXO voice interface daughtercard on Slot 0 SubSlot 1", DESCR: "2nd generation four port FXO voice interface daughtercard"

PID: VIC2-4FXO , VID: V03 ,

NAME: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1 on Slot 0 SubSlot 2", DESCR: "VWIC2-1MFT-T1/E1 - 1-Port RJ-48 Multiflex Trunk - T1/E1"

PID: VWIC2-1MFT-T1/E1 , VID: V01 ,

NAME: "PVDMII DSP SIMM with four DSPs on Slot 0 SubSlot 4", DESCR: "PVDMII DSP SIMM with four DSPs"

PID: PVDM2-64 ,

NAME: "High Density Voice2 Network module with on board two port interface on Slot 1", DESCR: "High Density Voice2 Network module with on board two port interface "

PID: NM-HDV2-2T1/E1 ,

NAME: "PVDMII DSP SIMM with four DSPs on Slot 1 SubSlot 2", DESCR: "PVDMII DSP SIMM with four DSPs"

PID: PVDM2-64 , VID: V01 ,

CUCM 7.0.2.20000-5

Why do you need this info?

Correct Answer
Nicholas Matthews Tue, 07/28/2009 - 05:26

Hi,

Normally the 'latest and greatest' is a good idea. The problem is sometimes there are new bugs in those versions that are not fixed yet. This is one of those cases.

I would download 12.4(15)T9 onto your MGCP gateway and try this again. The configuration looks correct.

Also, please check 'show controller t1' (or e1) and check for slips. If you have slips you have likely forgotten to use the 'network-clock-select 1 t1 0/0/0' command. If you have slips and that command present, you may have a wiring/provider issue.

hth,

nick

ronin2k8cronus Tue, 07/28/2009 - 22:04

This are some shows from one of the Routers

R-VOCE-E7-SPLAI#sh controllers e1

E1 0/2/0 is up.

Applique type is Channelized E1 - balanced

Cablelength is Unknown

Description: ## Romtelecom 1 ##

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20080918, FPGA: 13, spm_count = 0

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

Data in current interval (744 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

51 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

51 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

33352 Line Code Violations, 32 Path Code Violations,

5854 Slip Secs, 1 Fr Loss Secs, 2 Line Err Secs, 0 Degraded Mins,

5854 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 268 Unavail Secs

E1 1/0 is up.

Applique type is Channelized E1 - balanced

Description: ## Romtelecom 2 ##

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20080918, FPGA: 255, spm_count = 0

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

Current port master clock:recovered from backplane

Data in current interval (748 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

51 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

51 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

15022 Line Code Violations, 16 Path Code Violations,

5872 Slip Secs, 1 Fr Loss Secs, 2 Line Err Secs, 0 Degraded Mins,

5872 Errored Secs, 0 Bursty Err Secs, 2 Severely Err Secs, 13 Unavail Secs

E1 1/1 is up.

Applique type is Channelized E1 - balanced

Description: Description: ## Vodafone 1 ##

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20080918, FPGA: 255, spm_count = 0

Framing is CRC4, Line Code is HDB3, Clock Source is Line.

Current port master clock:recovered from backplane

Data in current interval (748 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

51 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

51 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

0 Line Code Violations, 11 Path Code Violations,

5873 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

5873 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

R-VOCE-E7-SPLAI# sh net

R-VOCE-E7-SPLAI# sh netwo

R-VOCE-E7-SPLAI# sh network-clocks

Network Clock Configuration

---------------------------

Priority Clock Source Clock State Clock Type

11 Backplane GOOD PLL

Current Primary Clock Source

---------------------------

Priority Clock Source Clock State Clock Type

11 Backplane GOOD PLL

R-VOCE-E7-SPLAI#sh run | i clock

clock timezone EET 2

clock summer-time EEST recurring last Sun Mar 2:00 last Sun Oct 4:00

network-clock-participate slot 1

network-clock-participate wic 2

I do have some slips. I don't know if that is too much and if that number of slips affects my fax communciations.

I have 3 E1's on this router from two diffrent providers, with each line getting the clock from the provider. What will the 'network-clock-select' command will do?

I am now downloading 12.4(15)T9 for my VGs and Routers and will come back with a reply as soon as possible(as soon as the client allows me to reload).

ronin2k8cronus Thu, 07/30/2009 - 23:57

I downgraded the images to 12.4-15T(9) and the problem seems to be fixed.

Looks like there is indeed a problem with the latest ioses regarding fax relay.

I'd like to thank everyone for their help in solving this problem

Have a nice day & bug free.

Actions

This Discussion