Wake on Lan with GBIC does not work ?

Unanswered Question
Jul 28th, 2009
User Badges:

I have a 3550-48 with two GBIC port. The issue is if the server plug in copper port (f0/0 - 48), even the server is power off the interface still light (WOL work) and we can power on and off server remotely, but if the server plug in GBIC port it does not work (no light).


IOS is " 12.2(35)SE".. Is there has special setting in GBIC port in order to WOL work properly, or the IOS?


Thanks for help

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
jbrenesj Tue, 07/28/2009 - 09:19
User Badges:
  • Silver, 250 points or more

What type of GBIC are you using?

Any info about the server's NIC?

rico_hao40 Tue, 07/28/2009 - 12:03
User Badges:

GBIC is WS-G5483

NIC is IntelPro 1000 MT

switch is WS-C3550-48

IOS is 12.2(35)SE


Leo Laohoo Tue, 07/28/2009 - 14:39
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I am suspicious that when the server is "powered off", the Intel NIC negotiates to 10/half BUT the G5483 will only "talk" at 1000/Full.


I hope I am wrong.

jbrenesj Tue, 07/28/2009 - 17:24
User Badges:
  • Silver, 250 points or more

It's correct, what you are seeing may just be an expected behaviour.

Looks like the laptops/PCs set the link

speed to 10 base T when they are WOL(wakeup on LAN) mode.

As the 1000Base-T GBIC can only support 1000 speeds the link doesn't come up.


So, this is not an issue with 10/100/1000 Ports. If the NIC card can't be set in 1000 base T mode when

it is WOL mode, then you can't use that GBIC.

This is also seen with Broadcom Gig NICS


- Jorge

Leo Laohoo Tue, 07/28/2009 - 17:32
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Thanks for the ratings, Jorge.


Intel's got some NICs (like the 8255DM) that presents this behaviour. And one of the ways to work around this is to hard-code the speed and duplex setting of both the NICs and the switch port.


A few options:


1. Put the server ports in 10/100 ports of the 3550. Gartner report of 2003 (I think) believes that ordinary servers don't have the CPU power to push genuine 1Gb worth of data.


and


2. Look for a different switch model.


Hope this helps.

Actions

This Discussion