too slow PPTP WAN connection on WRVS4400n v2

Unanswered Question
Jul 28th, 2009
User Badges:

Hi

Now I have Linksys/Cisco WRVS4400n V2 and ethernet link to provider with PPTP connection and 3Mbps speed limit.

When I use "Static IP" internet connection type and PPTP-link from workstation (WinXP) - I have 2-3 Mbps speed to internet. If I setup "PPTP" internet connection type - speed from workstation is very low, 60-100 kbps.

Status of PPTP connection on Linksys is "Up", internal PPTP-addresses is received.

IPS is disabled.

firmware 1.00.09-ETSI, and I dont find another for v2 on site. PPTP to my provider work normally with another devices from Dlink and Asus.


Need solution for normal PPTP-connection from WRVS4400n router.

thank you.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Carr Thu, 07/30/2009 - 07:36
User Badges:
  • Silver, 250 points or more

Try disabling some of the security features the router has like spi on the router and see if that speeds up the router a bit.

David Carr Thu, 07/30/2009 - 07:52
User Badges:
  • Silver, 250 points or more

Yes anything that is doing any type of packet inspection on the router will slow it down.  Make sure the mtu's are set to match the modem.  If dsl change the mtu settings to manual 1492 and if cable change to manual 1500.  Have you disabled the ips function on ther router yet and ran a speed test?

alex_hawk Thu, 07/30/2009 - 22:22
User Badges:

IPS was disabled, only signature loaded. And I already tried to change MTU (default is 1500, WAN - ethernet from provider switch) - no effect.

David Carr Fri, 07/31/2009 - 06:41
User Badges:
  • Silver, 250 points or more

With the pptp wan connection, the speed issue is with the isp.  You are using a pptp connection that uses authenication to connect and to maintain a connection. There isn't much more changes you can do to optimize the pptp wan connection you have setup.  If you could use the static ip connection, as you have already seen the speeds are much greater.

alex_hawk Tue, 08/11/2009 - 01:13
User Badges:

When I connect pptp to provider from local PC behind Linksys(static IP and firewall on Linksys) - speed from PC to Internet is 2-3 Mbps.

When I connect pptp to provider from Linksys (local IP on PC behind Linksys) - speed from PC to Internet is 80 Kbps.


No problem with speed issued by provider, troubles with Linksys.

alex_hawk Wed, 08/12/2009 - 22:59
User Badges:

Sorry, now I can not try this.

Problem is resolved, Linksys was changed to Dlink DIR-655 - no more problem.

JVlad001001 Mon, 03/29/2010 - 08:36
User Badges:

I'm going to purchase a router for my small company and WRVS4400n looked very promissing until I found this post. Ufortunately, my ISP provides only PPTP connection so I did a little research and found a review (in russian) stating that WRVS4400N throughouput is less than 1MBit when PPTP is on with all the defaults, except IPS which was turned OFF.

Is this problem already fixed?


Another question, how to recognize v2 model? Are there any special part numbers or signs on the box? I'm going to purchase in a local shop and their consultants aren't familar with such details.


Thanks in advance,

JVlad.

Actions

This Discussion