Unable to set DHCP option 60 on 2811

Unanswered Question
Jul 29th, 2009

I'm configuring a DHCP pool for 1240APs and I'm unable to set option 60. When I try to enter option 60 ascii "Cisco AP c1240" it sees the first space as the delimitter/end-of-line. This router is running c2800nm-spservicesk9-mz.124-15.T9. We have a similar config on 124-15.T7 and it is working properly. Is this an IOS issue or am I missing something?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Peter Paluch Wed, 07/29/2009 - 13:38


Can you paste the transcript of the terminal session with your router to see how does it complain?

In any case, enclosing the three words into quotes is the correct way to do it. If the IOS does not accept it then it might indeed by a glitch in the IOS.

Best regards,


freegraham Thu, 08/27/2009 - 14:26

I just ran into this problem myself and couldn't believe that Cisco says there is no workaround - Balderdash I say!

Don't use ascii, translate it into hex instead.

Here's a workaround that I just verified works for 1131 APs (I don't have a nice 1240 to play with)...

original ascii command:

option 60 ascii "Cisco AP c1130"

replacement hex command:

option 60 hex 4369.7363.6f20.4150.2063.3131.3330

I'm guessing that the 1240 equivalent would be:

option 60 hex 4369.7363.6f20.4150.2063.3132.3430



This Discussion