Trunk encapsulation

Unanswered Question
Jul 29th, 2009


I have already configured the switchport in trunk mode.

Once I configured it as trunk, I am not able to add the following statement

Switch1#switchport trunk encapsulation dot1q

It always fails. I also tried the following

Switch1#no switchport mode trunk

Switch1#switchport trunk encapsulation dot1q

still it doesnt accept the encapsulation statement.

please let me know, where I am going wrong



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jbrenesj Wed, 07/29/2009 - 08:38

In the 2950/2960 the ONLY encapsulation option is dot1q and it comes enabled by default once you use the switchport mode trunk command. This is all you need to set as the trunk will work with dot1q.

You can verify doing a:

sh int fa0/x switchport

It will tell you the

"Operational Trunking Encapsulation: dot1q"

iyde Thu, 07/30/2009 - 22:55


If you are able to do the "switchport mode trunk" command, then your switchport only supports 802.1Q encapsulation. If it supported more than one trunking protocol, then you would have to set the encapsulation before the switchport mode trunk.



This Discussion