IEEE 802.1ad / 0x88a8

Unanswered Question
Jul 29th, 2009
User Badges:

I have moved to another vendor at my edge, and I have continued to use 0x8100 as my ethertype which seems to play nice except for when a customer has a native vlan1 setup.


Vlan1 will get tagged into my SVLAN 301, but Cisco sees it as an incorrect BPDU, and shuts down the port. I also see customer CDP neighbor information, and other stuff when the customer doesnt prune his network down, or uses vlan1 on transparent lan services.


My new vendor told me to use the IEEE 802.1ad standard for the outter tag, (ethertype 0x88a8), but Cisco doesnt support it. Does anyone know why Cisco is not following the IEEE 802.1ad standard for provider bridges (Q-Q) tagging on the ME3400 series? I know they developed their own proprietary GBPT protocol for handling of L2 protocols but that doesnt help me now.


Just some quick searching, shows that the 7600 is supported with 12.2SR. ME3400's are not, its a 'future' release, but I dont know how long ago that document was written.


*May 10 18:30:30 MST: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up

*May 10 18:30:31 MST: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on GigabitEthernet1/0/1 VLAN301.

*May 10 18:30:31 MST: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet1/0/1 on VLAN0301. Inconsistent local vlan.


show spanning-tree vlan 301


VLAN0301

Spanning tree enabled protocol rstp

Root ID Priority 4397

Address 0017.5aaf.f200

This bridge is the root

Hello Time 2 sec Max Age 10 sec Forward Delay 7 sec


Bridge ID Priority 4397 (priority 4096 sys-id-ext 301)

Address 0017.5aaf.f200

Hello Time 2 sec Max Age 10 sec Forward Delay 7 sec

Aging Time 300


Interface Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/1 Desg BKN*4 128.1 P2p *PVID_Inc

Gi1/0/2 Desg BKN*4 128.2 P2p *PVID_Inc

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tstanik Tue, 08/04/2009 - 14:08
User Badges:
  • Bronze, 100 points or more

Currently, the default ether type is 0x8100 on a Cisco 7600 for the Q-in-Q outer tag. However, a few non-Cisco vendors use 0x9100 or 0x9200 ether type for the Q-in-Q outer tag. For Cisco 7600 router to operate seamlessly with other vendors it is required to provide a mechanism to change the default ethertype.


Moreover, there is a need to support ethertype 0x88A8 to support provider bridge defined by IEEE 802.1ad. Custom ethertype feature is proposed as a solution for this problem that enable change of ethertype as per requirements. Under the custom ethertype model, ethertype 0x9100, 0x9200 and 0x88A8 can be configured using "dot1q tunneling" CLI under a physical port.

Benefits


The explanation for the error message:

%SPANTREE-2-RECV_BAD_TLV: Received SSTP BPDU with bad TLV on [chars]

[chars].

Explanation The specified interface has received a Shared Spanning-Tree Protocol (SSTP) bridge protocol data unit (BPDU) that was missing the VLAN ID tag. The BPDU has been discarded.


Recommended Action If this message recurs, copy the error message exactly as it appears on the console or in the system log, call your Cisco technical support representative, and provide the representative with the gathered information.



sjamison76 Tue, 08/04/2009 - 15:57
User Badges:

Already opened a case, and closed. Nothing Cisco can do.


Replaced my Cisco Metro Core with another vendor in my Lab, and all works well now in my lab. (I did not have a 7600 in my production network where this was happening) Ill be replacing in my production network soon, just waiting on equipment to show up for this Ring and I expect the same results.


Situation only happens when Customer is using Cisco equipment, using vlan 1 and no inner tag can be applied to a PVST+ packet; and my core is CISCO with non Cisco edge equipment. Cisco thinks that the single tag is for that SVLAN, and reads it, which it shouldnt do. New vendor suggested moving away from 0x8100 and to 0x88a8 802.1ad but since its not supported on the Cisco ME equipment Im running, Im stuck. I cannot turn VLAN1 off either to ignore BPDU's for vlan 1. Nothing I can do but replace it. My Cisco SE also suggested the same.


I wanted to keep Cisco at my Core, but doesnt look like that will be the case. I did test using CIsco ME3400-2 at the edge, with non cisco in core, and everything works as expected as well.

Pavel Bykov Tue, 09/14/2010 - 21:20
User Badges:
  • Silver, 250 points or more

I know this comes a little late, as I have just stumbled upon this post for the first time. But it might help the others who are searching the forum.

Quick and easy fix is to turn on native vlan tagging. That way, there will be no "native" vlans, in a sense that none of the traffic will be sent untagged.

Actions

This Discussion