H323 (fast start)-SIP, Fax Config issue

Unanswered Question
Jul 30th, 2009

I have an issue where there is a CUBE(h323-sip) with a CCM 4.2 cluster setup. In Call Manager h.323 fast start is enabled outbound to the gateway with g729 set as the outbound codec, this was recently changed so that SDP is sent in the initial INVITE messages.

However, this configuration broke the way faxing is currently configured. In this setup, to send a fax, a user prefixes the dialed string with an 8. The gateway will use the 8 to match dial peer 300 and strip off the 8 before sending the call. However, since enabling fast-start, dial-peer 300 doesnt match since as it is set for g.711 and CCM sends g.729 in h.323 fast start.

I want to still be able to use fast start and g.729 codec for regular calls, but need to get faxes working again across the dialpeer 300. Thoughts?

dial-peer voice 300 voip

description Fax SIP dialpeer

translation-profile outgoing stripper

destination-pattern 8.T

rtp payload-type cisco-codec-fax-ack 114

rtp payload-type cisco-codec-fax-ind 113

no modem passthrough

session protocol sipv2

session target ipv4:x.x.x.x:5085

dtmf-relay rtp-nte digit-drop

codec g711ulaw

fax-relay ecm disable

fax rate 9600

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

no vad

!

dial-peer voice 100 voip

description VOIP dial peer to SIP_TRUNK

translation-profile outgoing SIP_OUT

destination-pattern .T

progress_ind setup enable 3

no modem passthrough

voice-class codec 1

session protocol sipv2

session target ipv4:x.x.x.x:5085

incoming called-number .

dtmf-relay rtp-nte digit-drop

no vad

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Nicholas Matthews Thu, 07/30/2009 - 11:47

You would need to do either one of two things:

-Change the outgoing codec in CUCM to G711

-Change the codec on the incoming dial peer on CUBE to be g729r8

As well, since you're using an MTP, you will want to add this to your dspfarm profile:

dspfarm profile 1 mtp

shut

codec passthrough

no shut

That way your MTP will allow T38 packets to be passed through your configuration.

hth,

nick

joshproano Thu, 07/30/2009 - 12:34

One item you may want to try is to configure a voice-class codec and set the first preferred codec to 729r8 with the second being G711U, then apply the voice class codec to the indbound voip dial-peer vs setting a single codec for the dial-peer.

Christopher Dozier Fri, 07/31/2009 - 09:41

I havent made an MTP change yet, but when adding a voice-class codec with g729r8, the dial peer matched, but the fax didnt work(the dial peer 300 matched as expected).

The call simply tried to fax over g729 it seemed.

Nicholas Matthews Fri, 07/31/2009 - 09:54

This will be a problem with the ATA. The ATA does not support T38, and only supports Cisco-proprietary methods of faxing.

Meaning, if you use a SIP trunk and the other end of the trunk is not doing a Cisco-proprietary method of faxing, your ATA will not be able to fax over the SIP trunk (or receive faxes).

You may want to look into getting something like a VG202 which supports T38, or putting the fax machine on a Router's FXS card, or VG224.

hth,

nick

Christopher Dozier Fri, 07/31/2009 - 09:58

ata 186.. Yeah I was think it may be the ATA. The other end of the SIP side is not Cisco, so it will not support the cisco proprietary method of faxing.

The whole issue of going to fast start in the first place is so that they could get an earlier media cut-through on voice calls (they were missing some messages such as "This number has been disconnected as dialed")

Actions

This Discussion