LMS on Virtual Machine

Unanswered Question
Aug 2nd, 2009

Is it LMS can work on virtual machine,client installed LMS 3.1 all application on Virtual machine by fulfilling the LMS hardware and software requirement.Am facing issues in LMS such as when clicking on RME Tab it get stucks and sometimes only RME,CM,IPM Tab's are displayed not CS and DFM.sometimes it gives me error unable to retrieve license and sometimes license are properly displayed,On Common services tab devices allocation summary show devices in RME,DFM,IPM,same as they are in DCR but when i go specically on DFM no of devices 0 and also same in IPM.

Does anybody know that it can work on Virtual machine server by fulfilling the cisco requirement(hardware and software) of LMS????

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
ciscoowsc Sun, 08/02/2009 - 08:28

Hi

is it the installation is proper can u pls have a look on pdshow command,

LMS3.1 is installed on VMware,Do LMS will faCE any issues on VMware.

Am facing the above issues it is due to wrong installation or due to VMware.

ciscoowsc Sun, 08/02/2009 - 10:02

Hi,

Can anybody reply me for the above query and also can tell me by verifying the installation of 3.1 is proper.

Lucien Avramov Sun, 08/02/2009 - 10:26

You are missing the some of the db services to be started.

Your screenshots errors :

-no devices in RME : have you run a discovery?

-CS: the log file is growing, that should not really be a problem at first sight. You can enable logrotation for this.

-RME issues on the portal: seems related to the missing services in pdshow.

The fact that services are not present in pdshow tend me to think the install did not run correctly.

Are you meeting the requirements for VMWare that are on the release notes?

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_lan_management_solution/3.1/install/guide/prereq.html#wp1103497

ciscoowsc Sun, 08/02/2009 - 11:19

Hi,

I have discovered devices in Common services 3.2.0 if i reinstall LMS 3.1 is it those devices will be as it is in CS 3.2.0 or i have to discover the devices again ?????.

Lucien Avramov Sun, 08/02/2009 - 11:22

You can run the perl script backup.pl to save your data. And then restore it.

Can you post your install log?

ciscoowsc Sun, 08/02/2009 - 11:48

Hi,

This is latest PDshow attached after i left office,the shift engineer after me have stopped and restarted the daemon manager,RME was succeded to pull the devices from the CS,but still there are no devices in DFM till yet.If am upgrading from 3.1.0 to 3.1.1 is it will work.If upgrade will work then which patch?? 3.1.1 will do or higher than this if it is available.

The strange issue with me is after restarting the services DFM application is not seen on LMS portal then again i have to stop and i have to restart the service then it comes Also the processes of LMS takes a very long time to start why such like this????

i didnt found such file by such name install.log in CSCOpx\log folder

I have to run backup.pl from windows command propmt?? and how i can restore that backup.

Appreciate ur help.

Thanks

Attachment: 
Lucien Avramov Sun, 08/02/2009 - 11:54

The processes take about 5 minute to start, it may be longer depending on the hardware. Also the jsp files are compiled are startup and this takes time as well.

If you are in process of a fresh install, why not install LMS 3.2?

The upgrade from LMS 3.1 is free.

You can run the restore.pl to restore the backup file.

I suggest that you start fresh on 3.2

ciscoowsc Sun, 08/02/2009 - 12:34

Tomorrow is my last day for project sign off LMS 3.2 will start all for me from scratch,Give me some alternate solution that DFM can work.Did u find anything serious in pdshow for DFM,

Which version is included for DFM in LMS3.2,if i installed that will it work for LMS 3.1 or suggest me an upgrade patch.

When devices are in DCR then why DFM is not pulling devices.

Am i missing anything???

Appreciate ur immediate reply.

Lucien Avramov Sun, 08/02/2009 - 14:16

According the last pdshow you posted:

DFM services are missing:

-DfmServer: service that polls devices

-EPMServer (service that correlates events into alerts)

-DFMLogServer

-DFMCTMStartup

-DfmBroker :interprocess mediator for dfm

What happens if you try to start those daemons manually :

For example:

cd /opt/CSCOpx/bin

pdterm DfmServer

pdexec DfmServer

You mentioned earlier you stopped and restarted the daemons, I hope you used the command net stop crmdmgtd / net start crmdmgtd (if on windows).

Or /etc.init.d/dmgtd restart (solaris)

the DFM logs will be needed to look at this further

MathieuJM_2 Sun, 08/02/2009 - 23:39

Hi all,

About virtualization can someone confirm me status of the support for LMS 2.6 and virtualization ?

Regards

ciscoowsc Mon, 08/03/2009 - 03:41

Hi,

How to run this command

cd /opt/CSCOpx/bin it gives me a error can u tell me the complete path.

I dont get any error for these two commands pdterm DfmServer,pdexec DfmServer they are executed sucessfully.

Am using the command net stop crmdmgtd / net start crmdmgtd to restart the daemon manager

which DFM logs u want and where can i find that.

Thanks,

lambay2000 Mon, 08/03/2009 - 07:21

Hi

DFMserver is down in process status when i restart it agains goes shutdown.

ciscoowsc Mon, 08/03/2009 - 07:36

Hi Lambay,

U too r in the same boat,though mine DFMServer is the same situation,

lavramov can u help me what are the causes that DFM is not able to cordinate with DCR.

Lucien Avramov Mon, 08/03/2009 - 09:05

Let's try to reinit the databases:

Stop LMS daemons (net stop crmdmgtd)

remove :

NMSROOT/objects/smarts/local/repos/icf/DFM.rps

NMSROOT/objects/smarts/local/repos/icf/DFM1.rps

Where NMSROOT is the folder where LMS is installed, for example:/Program Files/CSCOpx/

Then run: in NMSROOT\bin:

perl dbRestoreOrig.pl dsn=dfmInv dmprefix=INV

perl dbRestoreOrig.pl dsn=dfmFh dmprefix=FH

perl dbRestoreOrig.pl dsn=dfmEpm dmprefix=EPM

Start the daemons : net start crmdmgtd and import the devices from DCR to DFM.

Logs:

Turn on debugging at : Default Fault Manager->Configuration->Other Configurations-> Logging

the logs are the in NMSROOT/log/dfmlogs/

Actions

This Discussion