Half duplex connections

Unanswered Question
Aug 3rd, 2009

Hello folks -

I have a stack of 3750 switches that are trunked to several 2960 switches using MMF (LT/SC connector). The SFP that is in use is GLC-GE-100FX.

However, all the trunk ports between the 3750 and the 2960's are running on half duplex. There is no manual setting on either the 3750 or the 2960 configured for half duplex.

So I am not sure why these trunks are running at half duplex. On the 2960's, under the trunk interface, I don't even have an option to set the duplex manually.

Any thoughts would be appreciated.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Peter Paluch Mon, 08/03/2009 - 05:42

Hello Kunal,

Can you please paste the command output here that tells you about the half duplex connection? The SFP data sheet at


maintains that these modules operate at fixed full duplex and that this setting can not be changed.

Also, can you check the output of the "show interface capabilities" command? That should give us a glimpse of what the switch thinks about that SFP module.

Best regards,


ksarin123_2 Mon, 08/03/2009 - 08:38

Peter -

When I run the command "sh int g 0/1" on the 2960, it shows me the trunk port is running at half duplex.

When I enter the command "show int capabilities", it does recognize the SFP module.

Any other thoughts??

Peter Paluch Mon, 08/03/2009 - 09:14


Can you post the output of both commands here? Also, it is possible to post the port's configuration here?

Best regards,


jbrenesj Mon, 08/03/2009 - 14:54

This is expected on 2960's that have dual uplink ports (Copper and SFP) running FX SFPs.

The GLC-FE-100FX does not support autonegotiation and is set at 100/half by default. In order to set the duplex to full, you must first use the "media-type sfp" command on the 2960, and then set the duplex to full.

Switch(config)#int gi 0/1

Switch(config-if)#no media-type

Switch(config-if)#media-type sfp

Switch(config-if)#duplex ?

full Force full duplex operation

half Force half-duplex operation

Switch(config-if)#duplex full

Peter Paluch Mon, 08/03/2009 - 14:56


Thank you for this. I did not know about that. Thanks again!

Best regards,



This Discussion