Configure 1841 with HWIC-4ESW

Unanswered Question
Aug 3rd, 2009
User Badges:

I'm trying to configure a 1841 router that has a HWIC-4ESW switch module. The ports on the router are configured as: f0/0 - 192.168.1.1/24 and s0/0 - 192.168.2.1/24. I'm wanting to use the switch module to directly connect PCs who are on the 192.168.1.1 subnet. What is required to get this to work?


I created vlan1 and tied the switchports to it. If I set an IP to the VLAN, then the PCs can ping it but nothing is routed past it. I also tried moving the IP from f0/0 to f0/0.1 which was set to VLAN1. But when it comes to routing, I can get things to work. Am I just missing something simple? How do I tie the switchports to f0/0?


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Mon, 08/03/2009 - 09:05
User Badges:
  • Cisco Employee,

Hello Joe,


You can not tie the HWIC switchports to the onboard Fa0/0 and Fa0/1 interface. The HWIC is a separate module and its ports are independent of the built-in ports.


If you want to connect your PCs to the HWIC ports, there is a different way to configure it. Completely deconfigure your Fa0/0 interface - remove the IP address and all additional configuration to make sure that it does not conflict with the configuration you are about to add now. Also, just to be sure, shutdown the interface.


Now, I assume that your ports on the HWIC ports are recognized under the names Fa0/1/0 to Fa0/1/3 - if they have different names, use the real names instead of these here.


interface vlan 1

ip address 192.168.1.1 255.255.255.0

no shutdown


interface Fa0/1/0

switchport mode access

switchport access vlan 1

no shutdown


interface Fa0/1/1

switchport mode access

switchport access vlan 1

no shutdown


interface Fa0/1/2

switchport mode access

switchport access vlan 1

no shutdown


interface Fa0/1/3

switchport mode access

switchport access vlan 1

no shutdown


The configuration of the HWIC ports is very similar to configuring multilayer switches. You create and configure an virtual VLAN interface for the entire VLAN. That interface will hold the IP address and all necessary IP settings and it will serve as the gateway for all stations in that VLAN. The ports on the HWIC module are just Layer2 switchports and you configure them just like a switch - with VLAN membership and the mode of operation.


Let us know if this worked.


Best regards,

Peter


jplowick3 Mon, 08/03/2009 - 17:46
User Badges:

Didn't work for me. I even cleared the config and started from scratch. I configured the F0/0 port with an IP of 192.168.1.9/24 and is the "WAN" port (actually was connected to my home network). I then configured the vlan1 and switchports as shown above but with an IP of 192.168.2.1/24. My PC on the switchport (f0/1/0) had an IP of 192.168.2.10. I could ping the router from the PC. The router could ping the PC and sites on the "WAN" side. But I couldn't ping from the 2.x subnet over to the 1.x subnet. I even tried a default route in the router pointing to my home router (192.168.1.1). Port F0/1 is in a shutdown state and so is the serial port. I feel like I'm missing something simple and it's just not working.


Thanks the assistance!

jplowick3 Mon, 08/03/2009 - 18:13
User Badges:

I think it's working now. I just connected a PC to the F0/0 port (1.x subnet) and was able to ping the 2.x subnet. So things appear to be routing across the router interfaces. I think my problem earlier was improper routes in my home router.


Thanks!

Actions

This Discussion