Dialing Plan Question

Unanswered Question
Aug 3rd, 2009

I have an SPA921 IP phone at a remote site that is pointing to an SPA3102 gateway that has an old analog phone attached to it.  We can successfully dial each other and hear just fine.  The problem that I am currently having is that when I want to dial 9 to get out I immediatly get a fast busy.  My current dialing plan on my SPA921 phone is listed below -


Right now if I dial 1234 I can ring the analog phone attached to the SPA3102.  However, dialing 9 immediatly gives me a fast busy signal.  Is there something that I am missing?

Thanks! :)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
William Childs Mon, 08/03/2009 - 08:40

In this case you should be doing 2 stage dialing. If I am understanding your request correctly, you want to dial the 3102 and then have it send you to the pstn line attached so you can make a pstn call from a remote location. I will attach a document with instructions.

fairbanksf Mon, 08/03/2009 - 09:31

Thanks for the quick reply.  In your document you mention that I should start by registering the line and pstn tabs to the itsp.  I have no Internet Tele Service Provider.  We're just connected through a DSL line to a home PSTN line.

Am I misunderstanding something?

William Childs Mon, 08/03/2009 - 10:32

You don't have to have the line(s) registered. That guide is for the general user. In your case you would just set it so you could make calls without registration. You would still set it up for 2 stage dialing, however.

dhames Tue, 08/04/2009 - 10:53

Your dial plan should look something like this (assuming that you are using port 5061 for the PSTN line on the SPA3102):


Hope that helps.


fairbanksf Tue, 08/04/2009 - 14:43

Thanks for your input, but unfortunately I'm still unable to dial 9 to get out.  I've attached a copy of the 3102 config and the SPA921 config as well.  Is there something that I'm missing?

Thanks.  :)

dhames Tue, 08/04/2009 - 16:38

I checked out your configs and see a few changes that need to be made, however, I have one quick question.  Does the local Telco provider of your PSTN line require you to dial a 9 to make calls?

By putting a comma after a digit to your dial plan, the SPA devices can generate an "outside line tone" for you.  However, when you utilize this option, the device is going to send the 9, along with the rest of the numbers that you dialed, to the Telco provider.  In an office environment that's using a SPA9000, the 9 gets "stripped" at the trunk before it's sent out.  On a side note, I noticed that your PSTN port is set to 5070, so I adjusted it below.

Here are a few dial plans you can test out on the SPA921:

If the PSTN doesn't require 9:


If the PSTN does require 9:


This one is I haven't tested out in the lab yet, but I'm curious to see if it would work.  If it doesn't, let me know.

If the PSTN doesn't require 9, but you would like to utilize the "outside tone" feature:


Hope that helps.


fairbanksf Tue, 08/04/2009 - 17:36

Thanks for the quick reply and the advice.  The local telco provider does not require a 9 to dial out.  So if we can bypass that feature that would be great.  Is there any other necessary changes that need to be made in order to get the VOIP phone to ring when the home phone rings?  That is an issue we've been tackling with as well.

Thanks again! :)

dhames Tue, 08/04/2009 - 17:54

No problem.  Since the Telco doesn't require a 9 to be dialed, then I would change the dial plan on the SPA921 to the first option:


Referring to your question on having the VoIP phone to ring when the house number is called, you won't be able to do that.  The Telco would have to modify their call routing to include the unregistered phone.  Since the SPA3102 has 1 FXS (analog phone) and 1 FXO port (PSTN), you can have the VoIP line ring by setting the "Ring thru to line 1" option to yes.


fairbanksf Wed, 08/05/2009 - 06:42

For some strange reason I still am unable to dial out on the VOIP phone.  I changed the dialing plan, so that a 9 does not need to be pressed.  However, once I enter a number to be dialed I immediately get a fast busy.

Any suggestions or ideas? :(

dhames Wed, 08/05/2009 - 07:53

As long as the SPA3102 has an RJ-11 line running from the FXO port to the wall jack, it should dial out with no problems.  Would it be alright if I tested this in our lab?

On a side note, I'm unable to ping the SPA3102 at the address of

fairbanksf Wed, 08/05/2009 - 08:24

Ah, sorry for the confusion, I wasn't sure if I should put the real IP's on here.

SPA921 phone  - xxx.xxx.14.19

SPA3102 gateway - xxx.xxx.219.14

Thanks again for your help. :)

dhames Wed, 08/05/2009 - 14:06

No prob.  I replicated this in the lab.  When making a call using the dial plan I supplied, I get a "Forbidden" error on the phone.  I checked the configs you posted for the SPA3102 and saw where the Forbidden error was coming from.  Under the PSTN Line tab there's a place you can add up to 8 dial plans.  By default they are usually (xx.)  The first DP has (5678<:@>).  So when I make a test call, I'm restricted to that particular DP.  If you change it back to (xx.), it'll work.  Making this change will not prevent you from calling 5678.  That's properly setup on the Line 1 tab.

Let me know if that resolves the problem.



PS - Edit your last entry and remove the IP addresses now.  :-)

fairbanksf Wed, 08/05/2009 - 15:27

Sweet!  Hallelujah!  I can now dial out of the SPA921 to an outside line.  You're a saviour.

The final problem I'm facing now is that calls to the house are not ringing the SPA921 VOIP phone.  PSTN Ring Thru Line 1 is set for "yes", but for some reason it's not ringing thru.

dhames Wed, 08/05/2009 - 17:10

Awesome!   :-)

You would like for everyone that calls the PSTN line connected to the SPA3102 to ring the SPA921 as well, correct?

If so, I did some experimenting in the lab and got this to work.  :-D

On the SPA3102 - PSTN Line TAB

Type this dial plan in the "Dial Plan 2" field:

(S0<:[email protected]_IP_ADDRESS_OF_921_HERE>)

Enable the PSTN-to-VoIP Gateway (if it isn't already on)

PSTN Ringthru Line 1 set to "No"

Set PSTN CID for VoIP CID to "Yes"

PSTN Caller Default DP - 2

FXO Timer Valves

PSTN Answer Delay - 0

Let me know if that works for you.


fairbanksf Thu, 08/06/2009 - 06:40

Ah bugger.  I made your changes on this one, but when I dial the home number from say, my cell phone, after 1 ring I get a dialtone on the cell.  Perhaps something is incorrect with my current config.  I'll post it on here.

dhames Thu, 08/06/2009 - 07:38

No worries, I see what the problem is.  The dial plan that you put in DP2 has a lowercase "S"......yeah, unfortunately if it's not in uppercase, the device ignores it.

Change it from this: (s0<:[email protected]>)

To this: (S0 <:[email protected]>)

fairbanksf Thu, 08/06/2009 - 08:22

Ah!  I'm headed out of town for a week, but I shall try this fix as soon as I return.

Thanks again for your assistance Derek.  :)

fairbanksf Mon, 08/17/2009 - 09:18

Derek -

Thanks again for all of your help.  I've been able to test out the setup and everything works except one thing.  When a call is received at home, the office VOIP phone rings just great, but I cannot hear the person who called.  However, they can hear me clearly.  If I initiate a call and dial an outside number from the office VOIP phone, everything sounds great on both ends.

If the home analog phone calls the office VOIP, we can hear each other fine.  It's only if an outside caller calls the home, and then the call is answered in the office, I am unable to hear them.  Any ideas?  :(

dhames Mon, 08/17/2009 - 09:46

Typically this would be an issue with RTP ports not being forwarded.  On your router, make sure you have ports 16384 to 16482 (UDP) forwarded to back to the SPA921.  This should resolve the one way audio issue.

Let me know if that gets it.

fairbanksf Mon, 08/17/2009 - 10:59

Thanks for the quick reply.  I opened the port range, but still no luck.  There is no audio on the SPA921 end.  I'm not seeing anything on my firewall that shows rejected packets from the source SPA3102 IP. 

dhames Tue, 08/18/2009 - 17:51

Hey fairbanksf,

I'm unable to replicate the one-way audio issue that you are experiencing.  If it's not a port forwarding issue, it's possible that it could have something to do with NAT.  If you could, post a network topology, as well as any additional settings that could help.  (ie. one-to-one NAT, DMZ, etc.)

Thanks man,


fairbanksf Wed, 08/19/2009 - 06:54

Derek -

We're taking the IP phone up to the remote site today.  A small Linksys router is a lot more flexible than the higher end corporate firewall that I've been tinkering for the initial setup.  If we still have the same problem with no audio I'll let you know.  I'll agree, everything should be working correctly though.  It's just a NAT or firewall issue.

I'll keep ya posted on the results.

Thanks again...  :)


This Discussion