dtmf to uccx failing sometimes

Unanswered Question
Aug 3rd, 2009

UCCX version 7

CM version 7.0

H.323 gw, latest stable version of 12.4

Inbound calls to a uccx script, coming from the PSTN, DTMF fails 80% of the time.

Scenario is this: A caller on the PSTN dials an auto attendant script configured on uccx. UCCX answers and plays a prompt. At a digit collecting step, the caller enters, for example, a four digit extension. When it fails, UCCX only collects the last digit, instead of all four.


1. If I am doing a realtime debug on UCCX, the script ALWAYS collects the correct DTMF tones.

2. From an IP phone, this ALWAYS works.

Other info:

1. The codec is g.711

2. The dtmf relay method is h245-signal.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jonathan Schulenberg Mon, 08/03/2009 - 13:56

What do the TAPI traces show? Do they always show the correct digit was received; or, do they show the wrong signal event?

If the former, I would check to ensure your TSP is in sync. If the later, I would confirm your UCM and CCX versions are listed as compatible. If they are, I would open a TAC case.

steakandeggs Wed, 08/05/2009 - 13:57

Yep, JTAPI logs always show that the digits are received correctly. The versions appear compatible but I'm completely sure. Looks like TAC case time.You'll notice in the JTAPI logs below it is complaining of an invalid destination. On the same dialed digits a successful call doesn't say that. Might be worth a resync anyway.



GCID=(2,1124077)->ACTIVE]->ESTABLISHED]InvalidPartyExceptionImpl caught: Request failed because of an invalid destination.


This Discussion