PSTN dialing not working..

Unanswered Question
Aug 4th, 2009

Hi we have a Cisco 3845 voice gateway router. PSTN dialing is working fine with MGCP protocol...


However the same is not working with H.323 protocol.


Attached is the sh run and debug for 3845 router...


Using 0 dialing for PSTN and discarding 0 at route-pattern configuration.


Request help for this..


Regds,

Alok



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Tue, 08/04/2009 - 03:16

Too many attachments make posts awkward to read.

Summarize just the necessary information in the post itself. Eg, no full config is needed, just the DP config.

sebastiandm Tue, 08/04/2009 - 03:24

Try amend/ add the following dial peer


dial-peer voice 12 pots

description **Outgoing Calls**

destination-pattern 0.T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

port 0/1/0:15

Nicholas Matthews Tue, 08/04/2009 - 05:05

You're getting disconnected because of 'no circuit/channel available'. I would suggest running 'debug isdn q931' as you may have some problems on the PRI rather than H323.


It is also advisable to create an incoming dial peer:


dial-peer voice 100 voip

incoming called-number .

codec g711ulaw

no vad

dtmf-relay h245-alpha



If you would like to use G729, just omit the G711 statement.



-nick

jaiswalok Tue, 08/04/2009 - 07:23

Hi Nic,


I have already tested with the incoming dial-peer...still i am getting disconnected..


But if it is a issue with PRI then how come the outdialing is working with MGCP protocol....


with mgcp i don't have any issues..


But i can run mgcp as i have to test mobile connect and mobile voice access both....


require inputs for the same..


regds,

Alok

Paolo Bevilacqua Tue, 08/04/2009 - 08:34

Compare "debug isdn q931" for a mgcp and a h.323 call, and you will see why the latter is failing.

Actions

This Discussion