2841 router Flash is not detected

Unanswered Question
Aug 4th, 2009

Please help .

I have 2841 router but unfortunately when turn on router ,prompt goes to romon mode.After changing confreg 0x2102 & rebooting the router ,router does not come to normal.Show flash' does not contain any output on the flash.Please help me by a document.

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Peter Paluch Tue, 08/04/2009 - 09:39


According to the output you have posted here, the router does not even recognize the Compact Flash (CF) card.

Have you already tried to remove and reinsert the CF card? Sometimes they get loose and just a couple of disconnected pins can cause this problem.

If this does not help, do you have any other 2841 router with a similar CF card? If yes, try swapping the CF cards to see if the other card works in your router.

It can also be that your CF card is faulty. It has happened to me before and in fact there was a series of faulty CF cards that required replacement. It was documented in Cisco Field Notice document here:


While I doubt that you have one of those CF cards, it might be that it simply passed away. If that is the case, you can also replace it by a normal stock CF card (if possible not larger than 1GB).

Best regards,


Leo Laohoo Tue, 08/04/2009 - 14:09

Do you have any other 2821 or 2841 router available? If so, you can use that unit's flash and boot this unit that's having a problem.

Is this CF came with the router?

What is the size of this CF?

How to Download a Software Image to a Cisco 2600 via TFTP Using the tftpdnld ROMMON Command



This Discussion