Getting a CME 7.1 site phones to use central CM 4.2 directory

Answered Question
Aug 4th, 2009
User Badges:

We just deployed CME 7.1 at a remote loc. I need the CME phone to look at the central CM directory. I have entered in telephony-service configuration:


url directories http://x.x.x.x:8080/CiscoWebs/IPPhoneservices/CCMIP/xmldirectory.asp


no create cnf

create cnf


reset the phones and "Host not found"


I have read that you need to enter the CME phones in the CM as well but don't understand how to get phones registered to the CME router and CM 4.2 server at the same time.


Any assistance would be appreciated.

Correct Answer by Rob Huffman about 7 years 11 months ago

Hi Johnny,


The phones will not actually register with CCM 4.2 :) Also check the url, it doesn't seem right for a 4.x CCM version;


To enable an external directory resource on supported Cisco Unified IP phones and disable local directory services on those same phones, perform the following steps.


Prerequisites

To use a Cisco Unified Communications Manager directory as an external directory source for Cisco Unified CME phones, the Cisco Unified Communications Manager must be made aware of the phones. You must list the MAC addresses of the Cisco Unified CME phones in the Cisco Unified Communications Manager and reset the phones from the Cisco Unified Communications Manager. It is not necessary for you to assign ephone-dns to the phones or for the phones to register with Cisco Unified Communications Manager.


Restrictions

Provisioning of the directory URL to select an external directory resource disables the Cisco Unified CME local directory service.


SUMMARY STEPS

1. enable


2. configure terminal


3. telephony -service


4. url {directory | service} url ***something like http://172.16.242.240/CCMCIP/xmldirectory.asp


5. end



From this good CME doc;


http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmedirs.html#wp1015876



Hope this helps!

Rob



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Rob Huffman Tue, 08/04/2009 - 08:09
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Johnny,


The phones will not actually register with CCM 4.2 :) Also check the url, it doesn't seem right for a 4.x CCM version;


To enable an external directory resource on supported Cisco Unified IP phones and disable local directory services on those same phones, perform the following steps.


Prerequisites

To use a Cisco Unified Communications Manager directory as an external directory source for Cisco Unified CME phones, the Cisco Unified Communications Manager must be made aware of the phones. You must list the MAC addresses of the Cisco Unified CME phones in the Cisco Unified Communications Manager and reset the phones from the Cisco Unified Communications Manager. It is not necessary for you to assign ephone-dns to the phones or for the phones to register with Cisco Unified Communications Manager.


Restrictions

Provisioning of the directory URL to select an external directory resource disables the Cisco Unified CME local directory service.


SUMMARY STEPS

1. enable


2. configure terminal


3. telephony -service


4. url {directory | service} url ***something like http://172.16.242.240/CCMCIP/xmldirectory.asp


5. end



From this good CME doc;


http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmedirs.html#wp1015876



Hope this helps!

Rob



johnnywan Tue, 08/04/2009 - 08:13
User Badges:

Yep, figured it out. The URL provided is the one. I looked in the Enterprise parameters of the CM box and matched the CME URL entry to that. I then added all the CME phones to the CM as well. It is working. Thanks!

Actions

This Discussion