SRST doesnt work version 7.1

Unanswered Question
Aug 5th, 2009

hi,

we have a CUCM 7.1 and a 2821 ISR with SRST 7.1.

I created a SRST Reference at the CUCM and set it to the Devicepool of the phones.

The 2821 is configured as a h323 gateway.

I configured the call-manager-fallback at the gateway as following:

call-manager-fallback

secondary-dialtone 0

max-conferences 4 gain -6

transfer-system full-consult

user-locale DE

limit-dn 7910 2

limit-dn 7940 2

limit-dn 7960 2

limit-dn 7970 3

ip source-address 192.168.5.3 port 2000

max-ephones 24

max-dn 48

system message primary CM ist weg

system message secondary Notbetrieb

dialplan-pattern 1 XXXXX.. extension-length 3 extension-pattern 1..

keepalive 10

voicemail 50

translate calling 11

translate called 10

call-forward busy 130

call-forward noan 130 timeout 10

time-format 24

date-format dd-mm-yy

Then I go to test. I cut the network connection to the CUCM and degub the gateway. I see a 7970 phone is registerd with SRST at the gateway. It got an IP and the SRST-Message appears at the phone screen. But no softkeys are present, if i try to dial, i hear no dialtone at phone and i cannot dial. what helps?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Support Albakom Wed, 08/05/2009 - 05:27

in addition i found following:

the phones in CUCM are configured with extension mobility and user device profiles.

If i configure a phone without Extension mobility, the SRST works fine on this phone. I hear tones, I'm able to dial.

The phones with extension mobility get no tones or something if i lift up the handset.

Is this a new feature of CUCM and SRST 7.1? :(

rob.huffman Wed, 08/05/2009 - 06:06

Hi Albakom,

You need to look at the Default profiles for these phones to ensure connectivity during SRST fallback;

Q. Do Cisco Unified SRST support Extension Mobility?

A. Cisco Unified SRST routers do not support Extension Mobility. IP phones rely on the support from Cisco Unified Communications Manager for Extension Mobility support. When in SRST mode, IP phones fall back to the SRST router with whatever profile it contains (extension number, etc.).

http://www.cisco.com/en/US/prod/collateral/voicesw/ps6788/vcallcon/ps2169/prod_qas0900aecd8028d113.html

Hope this helps!

Rob

Support Albakom Wed, 08/05/2009 - 06:52

what you mean with default profiles? user device profiles? or under device >> device settings >> default device profiles?

i read the link you provided, but we have customers, they work with extension mobility and srst, and there it works. in case of fallback mode, the phones have the directory number of the user device profiles, if the user was logged in at the time. they don't use CUCM 7.1 - they use 4.1(3).

Support Albakom Wed, 08/05/2009 - 07:24

in addition to this:

i tried another phone: a 7960.

I create a 7960 user device profile.

I create a 7960 default phone profile.

I logged in to the 7960 with the 7960 profile and then go in fallback mode. it works. the DN of the user device profile is available and the phone works. I go back tu CUICM mode, logged out from 7960 and logged in again, but now with a 7970 profile. I go in fallback mode. Phone works and number of 7970 user device profile is available.

firmware problem at 7970? it has the newest sccp70.8-5-2S

Support Albakom Thu, 08/06/2009 - 00:20

someone an idea?

i now tried various versions of IOS:

c2800nm-spservicesk9-mz.124-15.T7.bin,

c2800nm-spservicesk9-mz.124-22.YB1.bin and finally c2800nm-advipservicesk9-mz.124-24.T1.bin, nothing works.

sebastiandm Thu, 08/06/2009 - 02:43

Silly Question,

Is this happening on all phones or just some. Also, are these phones actually logged in and do they have directory numbers when initialising SRST mode. Whichever profile is active on the phone at failover would be the one which would be present in SRST mode.

Support Albakom Thu, 08/06/2009 - 02:57

it happens on all phones by type 7970, 7975, 7961 and 7911 to.

only a 7960 works fine in fallback.

All phones dont work had the SCCP 8.5.2 firmware, only 7960 seems that has an older. Its an P00308010100. I dont reconfigure that. Its default by CUCM 7.1 installation.

The phones dont work with or without extension mobility, it dont work if a profile logged in or logged off. there are always directory numbers assigned.

the 7960 works fine in fallback with extension mobility or without this.

sebastiandm Thu, 08/06/2009 - 03:12

So if i understand you correctly a 7970 phone logged in with a 7970 profile, if SRST is activated the phone registers, the DN is on the phone but you dont get any softkeys.

Have you tried stop/restarting the tftp service and then resetting the phones.

You could try another firmware and just apply it to one phone.

Support Albakom Thu, 08/06/2009 - 03:25

in most youre correct. a 7970 logged in with a 7970 profile. if it goes in fallback, it registers at the SRST-Gateway. I see it with

>debug ephone register

. But there NO DN, and NO Softkeys. If i lift up the handset, NO dialtone is present.

But i see the SCCP Messages by lifting at the gateway debug output.

I tried to install some older firmware, but the phones loads always the 8.5.2, even so I switch the default loads in Phone settings load inforamtion at CUCM.

Support Albakom Thu, 08/06/2009 - 04:37

in addition: the SOLUTION

for your interest:

i tried to install an older firmware for 7970 again.

at this time it was successfully and the phone got the right load.

I use SCCP70.8-4-1.

After reset the phone with the right load, I logged in with a 7970 User device Profile.

The I disconnect the CUCM.

The phone immediatly register at SRST Gateway, if I lift up the handset. It got the DN of the User Device Profile and the Softkey also present. I hear a dialtone and can make incoming and outgoing calls.

So the question to cisco: why firmware SCCP8.5.2 doesnt work with SRST?

thanks to all for help.

iptuser55 Fri, 10/02/2009 - 05:04

Did anyone get to the bottom of this, I`ve also got a similar problem - fail over to SRST no dial tone on our handsets 7961 SCCP418-4-2S also downgraded it to 8-3-1S also failing, we are running 6.1.2

Keith Fulcher Wed, 10/21/2009 - 05:36

I upgraded to 8.5.3S and still does not work for me... I just opened a case. i will let you know what they say.

HARISH S Fri, 07/20/2012 - 04:19

Hai ,

Have you got this working ?

Is it a bug ?

What does cisco say.

I am facing same problem .I am having a home lab and I tell you when doing the last time also it worked .

Now its not working .Phones and dns are registered .But no dialtone .

I tried to test with both call-manager-fallback and telephony-service ,     srst methods.

debug ephone error

peer_vdb is null for DN 2 chan1 at SkinnyISPeerNONSCCP

I used and tested same phones multiple times in srst mode but suddenly now it came with this error .I am using 7.0(2) cucm which phone is registered and when it falls back to srst it gives this pbm.

Actions

This Discussion