IPCC Enterprise CAD Database Replication

Unanswered Question
Aug 5th, 2009

Hi all,

We have deployed IPCC Ent. with CAD.

We have recently noticed that there is a gap between the size of CAD Side-A FCRasSvr DB (170 MB) and the size of CAD Side-B FCRasSvr DB (5 MB).

FCRasSvr is the Real-time statistics DB.

We have also noticed that in CAD Side-A there is a publication but in CAD Side-B there is no subscription.

Does this mean that replication is not happening? How can we check this?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (1 ratings)
smahbub Tue, 08/11/2009 - 14:14

What is the version of your CRS deployment? Is it High Availability (2 CRS servers in the cluster)?

What is your CallManager version?

Where did you get the SQL install from? As part of the media kit to install CRS?

david.macias Wed, 08/12/2009 - 00:14

When you go to CAD admin can you use the synchronization tool? Also, have you tried to do a fail over test to see if CAD is accessible when either side is up?

david

geoff@hp.com Thu, 04/15/2010 - 13:40

Did you ever fix this?

I've been playing with SQL Replication of the FCRasSvr database in the lab system and seem to have busted it completely. This is a pain to fix.

1. I am logged in as the Local Admin

2. I can remove replication OK with C:\Program Files\Cisco\Desktop\bin\PostInstall.exe

3. I can reapply replication and it appears to have worked as far as CAD is concerned.

4. But SQL Enterprise shows it's well and truly broken. Lots of little red crosses in Replication.

Does anyone have any tips on this?

Regards,

Geoff

Irfan Tariq Javed Mon, 04/04/2011 - 23:31

TAC gave these steps

We also face this issue:

- SQL Backup to the CAD database Publisher
2 - Disabling the replication between 2 servers
3 - Insulation  the 2 databases of the 2 sides
4 - Reactivation of replication

after this we faced the issue of database size mismatch which was solved this way

This is a problem of SQL that generates the disappearance of the job SQL 'REPL-Merge'.
According to TAC, a first solution is to run the following action plan:

1 - Disable the replication of databases using the CAD tool and postInstall by logging in as local Administrator on the PG
2 - Enable the replication database using the CAD tool and postInstall by logging in as the local Administarteur PG
3 - Check that the SQL job REPL-Merge
4 - Check that the account used by the job REPL SQL-Merge is CADSQLAdminUser otherwise modify the job to use this account
5 - Make a daily check (for 5 days) to verify that the SQL job still exists REPL-Merge


geoff@hp.com Tue, 04/05/2011 - 10:22

Wow , you were responding to an old post of mine.

I've been through a few issues with replication and have solved it a few times now - including dealing with growth of the DB to over 2GB where it gets into an "Unknown" state (that's a good one to fix). Wrote an extensive paper for myself so I would not forget again.

You are right about the job owners. A Calabrio guy showed me that all those jobs should be owned by the CADSQLAdminUser.

Regards,

Geoff

Kenan Muharemagic Thu, 09/29/2011 - 08:14

Hi guys...

I was wondering... what is the CADSQLAdminUser password? I don't remember being asked to set up one during installation and am having replication issues at the moment?

Actions

Login or Register to take actions

This Discussion

Posted August 5, 2009 at 1:54 AM
Stats:
Replies:7 Avg. Rating:
Views:783 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard