Strange problem with phones

Unanswered Question
Aug 5th, 2009

We just deployed some 7965 phones and have had complaints that when users are on a call and then have to imput more numbers (bank info, passcodes etc) the numbers double or triple. So for example they hit 43872 it shows 44444433388888777777772222. We have deployed hundreds of these phones and have never had this issue? We replaced a few phones but the users still experience the issue.

Ideas?

Thanks,

Mike

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
rob.huffman Wed, 08/05/2009 - 06:22

Hi Mike,

It's likely this "Firmware" related bug (nicely supplied by Nick!)

CSCsv04751 Bug Details

DTMF is not squelched on third gen phones causing duplicate DTMF

Symptom:

Duplicate DTMF is detected and users have problems entering DTMF mid-call. The side tone from the phone appears to be introduced into the RTP stream in addition to the out-of-band signaling normally sent.

Conditions:

This occurs independently of the Call agent, and is seen on both CUCM and CUCME, and is observed on SCCP phone load 8.4.1 SR 1.

Workaround:

Both speaker phone and the headset use a different sidetone than the handset, and they should should not experience the same DTMF problem. Downgrading the firmware is the only other workaround.

Status

Fixed

Severity

2 - severe

Last Modified

In Last Year

Product

Cisco Unified IP Phones 7900 Series

Technology

1st Found-In

8.4(1)

8.5(1)

Fixed-In

8.4(1.21)

8.4(1)ES9

8.4(2.16)

6.1(3.1000.8)

4.1(3)ES150

6.1(3.1000.16)

4.3(2)ES9

4.2(3)ES73

4.1(3)ES151

4.2(3)ES74

4.3(2)ES11

4.1(3)ES153

Hope this helps!

Rob

Nicholas Matthews Wed, 08/05/2009 - 06:44

I'll actually disagree here. The bug I filed that Rob mentioned should have a functional limitation on duplicating it by 1 number.

This is of course, unless you're hitting a 'perfect storm' of duplicate DTMF with multiple bugs/issues.

If you're on 8.4.1 SR1 by all means upgrade your phones and see if you get less duplicate digits.

If your gateways are on 12.4(15)T7 or lower, or 12.4(21) or lower, upgrade those as well to 12.4(15)T9 or 12.4(25).

If you're using MGCP, switch your DTMF method from nte-gw if you're using that to nte-ca.

Otherwise you have a different issue that is a duplicate DTMF problem that creates more than 1 digit. If these don't work, open a TAC case and let me know the SR, and I'll take a look. I've had a particular interest in duplicate DTMF recently.

-nick

burleyman Wed, 08/05/2009 - 07:48

Thanks for the information I will check things out and see how it works.

Mike

burleyman Wed, 08/05/2009 - 08:08

We are running 8.4.1 SR1 on the phones.

We are running vg224-i6s-mz.124-24.T1.bin on the gateway.

I looked at the config and did not see nte-gw or nte-ca

Here is the config we have

Building configuration...

Current configuration : 3272 bytes

!

! Last configuration change at 15:25:08 EST Tue Jul 28 2009

! NVRAM config last updated at 15:25:13 EST Tue Jul 28 2009

!

version 12.4

no service pad

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

no service password-encryption

!

hostname roc_VG224

!

boot-start-marker

boot system slot0:vg224-i6s-mz.124-24.T1.bin

boot-end-marker

!

logging message-counter syslog

logging buffered 20000

no logging monitor

!

no aaa new-model

clock timezone est -5

clock summer-time EST recurring

ip source-route

ip cef

!

!

ntp server 10.10.1.1 source FastEthernet0/0

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0/0

ip address 10.10.4.226 255.255.255.0

duplex full

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.10.4.1

ip http server

!

logging trap warnings

logging 63.118.88.137

!

snmp-server community RW

snmp-server community RO

snmp-server community RO

!

control-plane

!

!

!

voice-port 2/0

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

ccm-manager redundant-host 10.10.4.10

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.10.4.10

ccm-manager config

!

mgcp

mgcp call-agent 10.10.4.13 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 ecm

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0

mgcp bind media source-interface FastEthernet0/0

mgcp behavior g729-variants static-pt

!

mgcp profile default

!

!

!

dial-peer voice 99922 pots

service mgcpapp

port 2/2

!

dial-peer voice 99925 pots

service mgcpapp

port 2/5

!

dial-peer voice 99926 pots

service mgcpapp

port 2/6

!

dial-peer voice 99929 pots

service mgcpapp

port 2/9

!

dial-peer voice 999210 pots

service mgcpapp

port 2/10

!

dial-peer voice 999211 pots

service mgcpapp

port 2/11

!

dial-peer voice 999214 pots

service mgcpapp

port 2/14

!

dial-peer voice 999213 pots

service mgcpapp

port 2/13

!

dial-peer voice 999212 pots

service mgcpapp

port 2/12

!

dial-peer voice 99920 pots

service mgcpapp

port 2/0

!

dial-peer voice 99923 pots

service mgcpapp

port 2/3

!

dial-peer voice 99927 pots

service mgcpapp

port 2/7

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

password

logging synchronous

login

line aux 0

privilege level 15

password

logging synchronous

login

line vty 0 4

privilege level 15

password

logging synchronous

login

transport input telnet

!

end

Thanks for your help.

Mike

Actions

This Discussion