How to tftp backup config file automatically ?

Unanswered Question
Aug 5th, 2009

Hi Experts,

I have Solarwinds Tool install on the server and would like to know how i can push my backup config file automatically for routers/switches to the TFTP SOlarwind?

I would like to do schedule as well like, every month , 12 midnight , the config will be push over..



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
dhananjoy chowdhury Thu, 08/06/2009 - 03:36


You can automate the config backup

using the archive command .

But this is available only on 12.4 ios.

you can explore more on this.

Here are the options..



Archive configuration commands:

default Set a command to its defaults

exit Exit from archive configuration mode

log Logging commands

maximum maximum number of backup copies

no Negate a command or set its defaults

path path for backups

rollback Rollback parameters

time-period Period of time in minutes to automatically archive the


write-memory Enable automatic backup generation during write memory


Router(config-archive)#path ?

ftp: Write archive on ftp: file system

http: Write archive on http: file system

https: Write archive on https: file system

pram: Write archive on pram: file system

rcp: Write archive on rcp: file system

scp: Write archive on scp: file system

tftp: Write archive on tftp: file system

pompeychimes Fri, 12/04/2009 - 08:42

Do you get the same results when you do upload the config via tftp manually? Have you considered using a tool like CiscoWorks, CatTools, etc... to handle the backups?


My TFTP connection is fine. If I do the "archive config" command it works fine, including the actual config. When I let it do it automatically using the time-period command my config file it transfers is this:

! Last configuration change at 11:16:46 EST Fri Dec 4 2009
! NVRAM config last updated at 11:11:32 EST Fri Dec 4 2009

I'm just trying to figure out what I'm missing with the built in commands that seem like they should do what I want.

cachapman86 Thu, 11/18/2010 - 14:54


I am having this same problem right now, nearly exactly.  Except I am using FTP instead of TFTP.  A few of my switches will do it just fine when I let it do it automatically with the time-period specified.  However, a few of the switches are still outputting the 1kb file mentioned above, rather than the full running-config.  These switches are using the same IOS versions, and it looks like I set everything up the same.  Any suggestions?

michael.baldoza Wed, 02/09/2011 - 12:13

Mine is also having the same problem. I tried to do the archive  config setting it to a time-period of 1 minute and also tried to set it  into 10 minutes auto archive but still the problem persist having a 1kb  archived file.

for 1 minute time interval

path scp://user:[email protected]//cygdrive/e/backuprunning-configs/Discovery/router
time-period 1

tried also for 10 minutes interval

path scp://user:[email protected]//cygdrive/e/backuprunning-configs/Discovery/router
time-period 10

I am using OpenSSH as my SCP server. Is there something that I have missed?



cadet alain Wed, 02/09/2011 - 23:46


if you've got this bug with the archive feature then maybe you can try a kron job like this:

kron policy-list Backup

cli show run | redirect ftp:////xxx.cfg Note: We can do the copy command because kron doesn't execute interactive commands

kron occurrence Backup_occurence at 01:15 recurring

policy-list Backup



michael.baldoza Wed, 02/16/2011 - 09:09


Thanks for the reply on this thread I already resolved my problem but my kron config is about automatic write because after the equipment saved its config its automatically transferring the startup-config to data server using SCP. I didn't do the ftp transfer due to unsecured transfer of configs.



This Discussion