boot system flash question

Unanswered Question
Aug 6th, 2009

Hi,

I used to put <boot system flash c2800nm-spservicesk9-mz.124-15.T8.bin> in the past.

But looking up the command lookup on boot system flash, it seems it shows it should be :

<boot system flash flash:c2800nm-spservicesk9-mz.124-15.T8.bin> instead.

But then from the router below it didn't really show the option to put the "flash: before filename it seems" so I am little hestiated which way should I put the command (with or without flash: after boot system flash).

router1(config)#boot system flash ?

WORD System image filename

<cr>

My router is 2811 and 2801 with 12.4.15T8 SP services in it.

I think I read somewhere says the router to boot twice when flash: is not in the command but then if that is the case, the output didn't show we should enter the flash file system indicator then?

Command reference:

Booting from a System Image in Internal Flash

boot system flash [flash-fs:] [partition-number:] [filename]

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
John Blakley Thu, 08/06/2009 - 06:48

The correct syntax is what you've done in the past. You don't need the extra flash: path before the filename:

boot system flash

HTH,

John

blackladyJR Thu, 08/06/2009 - 07:08

Hi John,

Does it hurt to add flash: to it? It seems we can omit the flash: and it will use default flash file system according to below. But then does that mean it does not hurt by putting it in? Or does it apply to older router (non-ISR) where you need to specify the flash slot...etc while ISR we don't need to anymore?

From command reference:

filename

(Optional when used with the boot system flash command) Name of the system image to load at startup. This argument is case sensitive. If you do not specify a value for the filename argument, the router loads the first valid file in the following:

•The specified flash file system

•The specified partition of flash memory

•The default flash file system if you also omitted the flash-fs: argument

John Blakley Thu, 08/06/2009 - 07:12

You can specify it like this, and this is the way that I have mine:

boot system flash:

I've never seen a config that had flash specified twice like:

boot system flash flash:

So I'm not sure it would hurt, but I'll try it and let you know. I'll get back with you.

HTH,

John

John Blakley Thu, 08/06/2009 - 08:38

Okay, both ways work fine.

I have two images on one router, and I can do either:

boot system flash

or

boot system flash flash:

and both come up normally with the correct image that I specified.

HTH,

John

blackladyJR Thu, 08/06/2009 - 10:07

Hi John,

So that makes me wonder which is the correct way going forward from Cisco's perspective I guess? Maybe some older router that has more than one flash slot, then perhaps you will need to indicate which slot to copy the ios into...etc I am guessing.

I put it the good old way this morning on a customer router which 2 IOS in it. It comes up okay but I do notice it has decompressed the image twice while I was watching the reload progress via console. I am also going to try to test it later in the afternoon in a lab router to see if it boot twice or not.

thanks,

Joyce

blackladyJR Thu, 08/06/2009 - 11:16

This URL is what I was looking at prior to posting and I copied some of the output from that reference in this message chain. So that prompts me whether we should or should not include the extra flash: after boot system flash?

slmansfield Thu, 08/06/2009 - 12:42

Honestly, I have never put two "flash" parameters in the statement.

It seems that we are all in agreement that only one is needed.

Leo Laohoo Thu, 08/06/2009 - 13:57

If I have only one IOS in the router, I make it a point to REMOVE this statement. But if I have two, I always use the "boot system flash:" out of habit. I have tried using "boot system flash " in the past with some mixed result so I went with the former.

It is alot better nowadays, I remembered a few years back that without the boot statement a router will read the first file rather than the first .bin file.

Hope this helps.

blackladyJR Thu, 08/06/2009 - 14:06

Hey Leo,

It's you again! Remember you helped me on all those USB boot stuff with numerous email back and forth :)

Yes, I think we all agree there is no reason to have that statement if there is only 1 IOS in the router, thanks for clarfying though :)

Do you use boot system flash flash: or do you use boot system flash:?

Looking at the command reference, it seems we can do boot system flash flash:.

So we actually have 3 ways to do this:

1. boot system flash

2. boot system flash:

3. boot system flash flash:

I plan test it out all 3 ways a few times to see which is better. I only noticed this morning with a customer router that I go with #1, it seems to have 'decompress" the image twice during the reload so wasn't sure if this has anything to do with the #1 version. So I will test it again and find out.

I won't have lab access until next week so will test it at that time.

Thanks for your input.

Joyce

Leo Laohoo Thu, 08/06/2009 - 14:35

Hi Joyce,

Sure I remembered. How did the USB exercise go?

As a habit, I always use the boot system flash: syntax when two or more IOS are involved.

Now if I have two or more IOS, I always have two or more boot statement.

boot system flash:

boot system flash:

boot system flash:

If router boot fails with filename_1 then go to filename_2. If filename_2 fails then use filename_3. If filename_3 fails ... you may consider putting in your leave now.

I think we all agree there is no reason to have that statement if there is only 1 IOS in the router -- Yes I agree but it never ceases to amaze me when I see as appliance with ONE image and you have this statement and the image in question happens to be the WRONG image! Grrrr ... who hid the baseball bat I have under my desk?

Actions

This Discussion