6500 VSS Active/Standby Issue

Answered Question
Aug 6th, 2009

I have configured such that switch 1 always be the active role. Last night, Switch 1 lost power; Switch 2 became active, however, when power restored to Switch 1, it came up as Standby and did not transition to Active. Below are the details as configured on the switch:

switch virtual domain 100

switch mode virtual

switch 1 priority 200

switch 1 preempt

!

redundancy

main-cpu

auto-sync running-config

mode sso

!

However, a Show Switch virtual:

Switch mode : Virtual Switch

Virtual switch domain number : 100

Local switch number : 2

Local switch operational role: Virtual Switch Active

Peer switch number : 1

Peer switch operational role : Virtual Switch Standby

So - Why did Switch 1 Not assume the active Role? Is something missing in my config?

Thanks,

Tim

I have this problem too.
0 votes
Correct Answer by Rams.Dandu about 7 years 3 months ago

Hi Tim;

Eventhough you configure preempt, if you haven't did a copy-run-start it will disable the preempt command so that the active switch will not loose the running config. so try copying the running config to startup and it should work normally.

Make sure you always issue copy run start everytime you do some changes. For a preempt to work both the startup and running config should be same.

Hope to help;

Rams

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Tim Johnson Thu, 08/06/2009 - 10:26

A) Not sure we are on the same page. Being a virtual switch - the config is synced between the switches. Switch 2 will have a copy of the running config from Switch 1. Once the stand-alone switches are converted to virtual, the only thing in the config is the following:

switch virtual domain 100

switch mode virtual

switch 1 priority 200

switch 1 preempt

Documentation states that priority 200 and preempt inform the switches to make switch 1 the active role after the default 15 minute standby preempt.

(B)sho switch virtual role

Switch Switch Status Preempt Priority Role Session ID

Number Oper(Conf) Oper(Conf) Local Remote

------------------------------------------------------------------

LOCAL 2 UP FALSE(N ) 100(100) ACTIVE 0 0

REMOTE 1 UP TRUE (Y*) 200(200) STANDBY 9483 416

Standby configured preempt timer(switch 1): 15 minutes

In dual-active recovery mode: No

Thanks,

Tim

Correct Answer
Rams.Dandu Fri, 08/07/2009 - 01:04

Hi Tim;

Eventhough you configure preempt, if you haven't did a copy-run-start it will disable the preempt command so that the active switch will not loose the running config. so try copying the running config to startup and it should work normally.

Make sure you always issue copy run start everytime you do some changes. For a preempt to work both the startup and running config should be same.

Hope to help;

Rams

Tim Johnson Fri, 08/14/2009 - 06:39

That's exactly what it was. I am in the habit of the older "write mem" and need to change to the "copy run start". Thanks for the quick responses everyone.

gnijs Sat, 08/15/2009 - 04:09

there shouldn't be any difference between wr mem and copy run start.

Both commands syncronise the startup config.

002877: Aug 15 14:07:09.138 CEST: %PFINIT-SW1_SP-5-CONFIG_SYNC: Sync'ing the startup configuration to the standby Router.

it means your config was just not saved. and therefore there was no pre-empt.

Actions

This Discussion