Cisco 871w performance issues

Unanswered Question
Aug 6th, 2009
User Badges:

Hello,


We are trying to download ubuntu via bit torrent on our Cable internet connection.


This router is connected directly to the modem.


After a few minutes all traffic gets halted. I can console into the router and can't ping out anymore. When the torrent is running the CPU never gets above 24% on the router. We have a 20mb connection and we never get above 800KB with like 50+ seeders.


I have seen 2 different links from Cisco that quote 50mb and another quotes 12mb so I doubt we are beating up this router.


Please find the relevant information attached which shows the troubleshooting steps which I took.




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Thu, 08/06/2009 - 21:16
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

It is not a performance problem, it's a bug, likely some data structure gets corrupted in presence of many connections.


Upgrade IOS and hope it won't happene again.

jholding09 Thu, 08/06/2009 - 21:37
User Badges:

This version of IOS is supposed to be the most stable and I have tried many others and I get the same result.


Just doing normal speed tests from testmy.net and dslreports I never get over 6mb so I am guessing there is something else wrong with it.


Thanks!

paolo bevilacqua Thu, 08/06/2009 - 21:45
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

The cable modem, is doing NAT also, or do you get a public IP on fa4 ?


What is the reason you reduced tcp mss to 1452 ?


How do you recover from this loss of connectivity ?

jholding09 Thu, 08/06/2009 - 22:58
User Badges:

The cable modem hands out a public IP address.


I have just testing different MTU values I was messing with TCP values which didn't make any difference.


The only way to recover is with a reload. This has happened on 12.4(3) (9) and now (24). I have even tried the advanced security and advanced IP services and it still continues to happen.

paolo bevilacqua Fri, 08/07/2009 - 03:47
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Do not assume these are stable release just because someone says so.


Certain bugs go undetected or un-acknowledged by cisco until someone is persistent enough to prove his case.


I use 12.4(9)T7 on a 851w without issues, but often you have better results going backward in trying releases.

Actions

This Discussion