Web Authentication - Web login page not displayed

Unanswered Question
Aug 9th, 2009
User Badges:

Cisco 4402 WLC running version 5.2.193.0

Access Points: AIR-LAP1142N


I have configured an SSID for WebAuthentication. When a wireless client logs into the WLAN the PC will associate to the AP but will then stop at the WEBAUTH_REQD stage.


Internet Explorer will show the attmept to redirect to the virtual port at 1.1.1.1 but will not bring up the login page.

IE shows : https://1.1.1.1/login.html?redirect=www.google.co.ukhttp://www.google.co...


The network is a flat network so this SSID is using the management interface.


DHCP is being provided by the controller for this WLAN.


I know the classic design should be for this to be implemented on a separate VLAN but my customer has not VLANed his network yet and this is planned at a later stage. I have implemented this on a flat network before and it has worked.

Any suggestions would be much appreciated.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
BrianJ2007 Sun, 08/09/2009 - 04:53
User Badges:

Important bit of information left of the original entry.


Debug Client results in the following message for every attempt to log onto the WLAN:


Orphan Packet from 10.0.0.55 on mobile


Where 10.0.0.55 is the IP address of the laptop.

zhenningx Sun, 08/09/2009 - 15:33
User Badges:
  • Bronze, 100 points or more

Can you client resolve DNS properly? If cannot resolve DNS, web auth page cannot load.

wg wireless Thu, 08/13/2009 - 00:11
User Badges:

If the client is going through a proxy server, put virtual interface IP (eg. 1.1.1.1) in proxy exception of client LAN settings

harsisin Tue, 10/27/2009 - 11:28
User Badges:

I faced exactly the same problem as you have described above. The following is what fixed it for me, i am sure u try it to might fix it for u as well.


In my scenario i found that my WLC controller had cipher-option sslv2 disabled. I enabled it and that resolved the issue for me.


This is what needs to be done in order to do it :-


It's best to enable it on the WLC and this is done from the CLI. It requires a reboot.


ssh to the WLC


enter the following command:-


WLC>config network secureweb cipher-option sslv2 enable


and then reboot.


Once the WLC reboots u can check the status by issuing the following command:-


WLC>show network summary

The output should look similar to the following


RF-Network Name............................. GTCR-CH-RF-GA

Web Mode.................................... Enable

Secure Web Mode............................. Enable

Secure Web Mode Cipher-Option High.......... Disable

Secure Web Mode Cipher-Option SSLv2......... Enable


As u can see the Secure Web Mode Cipher-Option SSLv2 is now enabled.


This should work.


Hope this helps and all the best.


Actions

This Discussion

 

 

Trending Topics - Security & Network