OSPF/IS-IS to Multicast BGP redistribution

Unanswered Question
Aug 9th, 2009
User Badges:

Hello,


Has anyone tried that? I tried it on 3640 with c3640-jsx-mz.124-25a.bin

and on 7206 VXR with c7200-k91p.122-25.S13.bin and it doesn't work. However, RIP and EIGRP are redistributed into MBGP without a problem (also connected and static). There is a workaround - to do it with network commands but that doesn't scale well. Anyone aware of a particular reason for that behavior? Checked the Bug Toolkit - nothing comes up. Documentation also does not mention any restrictions. Looks like neither a bug, nor a feature:)


Cheers,


Stefan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
thegrave2000 Sun, 08/09/2009 - 07:58
User Badges:

Mystery partially solved. With IS-IS it's necessary to redistribute into Unicast BGP as well. Then the prefixes appear in the Multicast BGP table. However, with OSPF this doesn't work. If only somebody can give me a reasonable explanation why would someone code it this way...

Actions

This Discussion