Slow internet upload speeds via ASA and 3750

Unanswered Question
Aug 10th, 2009

Hello,

I have a Cisco ASA and a 3750. We have a 50mb lease line and are getting nearly the 50mb download speed, but only 10mb upload speeds.

As per the attached diag.jpeg we have (among others) 2 VLAN's, one for the inside of the ASA (LAN) and one for the outside (ISP Cisco router).

If I plug my laptop into the outside VLAN on the 3750 (give it a public IP etc) I get 47mb download speeds and roughly the same for uploads so I know it's not the IPS or the router. If I put my laptop into parts of our LAN I get 10mb upload speeds only.

I then created another VLAN on the 3750 (to prove it's not the LAN) and get 47mb downloads speeds but again 10mb upload speeds. Seems the 3750 or the ASA is created soem sort of bottleneck, would you agree?

Where do I start as I did create an any any rule for my laptop and it made no change. I turned off IPS on the ASA, made no difference. I turned off Websense, made no difference....

Kind Regards

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jamesgonzo Tue, 08/11/2009 - 06:59

The ASA config is huge and many parts are sensitive, can I post justthe parts you need?

Thanks

nsn-amagruder Sun, 09/20/2009 - 07:41

Speed and Duplex is the first thing I would check. Is the switch linking at auto 10/100 or are both sides hard set at 10/100? I'd suggest auto as the 5520 has gig interfaces.

What interface are you running state over? I usually use a dedicated interface for failover and state.

What is the trunk interface for?

Aaron Magruder

NonStop Networks, LLC

http://www.nonstopnetworks.net

Actions

This Discussion