C2940-8TT - IOS Upgrade

Unanswered Question
Aug 10th, 2009
User Badges:

By mistake I got rid of the IOS file from my switch. I downloaded the version 121-22.EA13 and now I got an error saying DRAM is not sufficient and I can't find a version that will fit.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Lucien Avramov Mon, 08/10/2009 - 09:00
User Badges:
  • Red, 2250 points or more

Contact TAC to get an older image that will work.

javier.castillo Mon, 08/10/2009 - 10:10
User Badges:

Well, before going to the TAC option, I did copy the latest IOS .bin (the one was giving me the error) by using xmodem and it went good. After it I re-tryied the upgrade using the "archive downlad" command and now it worked.

Don't know why it wanted to do the upgrade before though.

Lucien Avramov Mon, 08/10/2009 - 10:15
User Badges:
  • Red, 2250 points or more

Perhaps the previous file was not copied over the switch properly. Not sure what happened. If you still have an issue we can investigate further.


If the problem was that you cant find on our website an image that works for your switch, then TAC would have been of help as that is what I understood from your first post.

iyde Tue, 08/11/2009 - 05:45
User Badges:
  • Silver, 250 points or more

If my memory isn't totally blown away, then I believe that I have seen that the image size is close to what the 2940 can handle in it's DRAM/Flash.

Perhaps your upgrading via XMODEM has deleted some other files which has made enough space for your renewed archive download.

HTH.

javier.castillo Tue, 08/11/2009 - 06:03
User Badges:

It could be...

The good thing is that I was able to do the upgrade after all.


Thank you all for your feedback!

Actions

This Discussion