Remove dial 9 for one analog extension

Answered Question
Aug 10th, 2009

Hi, I have a fax modem that gets it's outbound numbers from a proprietary application (not mine). The fax modem is set for "dial as entered", I would like to use it on the outbound sip trunk, but need to disable dialing the 9 to access an outside line..

I have this problem too.
0 votes
Correct Answer by Steven Smith about 4 years 8 months ago

You could put a translation profile on the ephone-dn that adds a 9.  This wouldn't be CCA supported, but it would mean not having to change the rest of your dial plan.

config t

ephone-dn 4

voice translation-profile outgoing faxadd9

voice translation-profile faxadd9

translate calling 4

voice translation-rule 4

rule 1 /\(^.*\)/ /9\1/

Something like that should work.  Use this page for a reference.
http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Correct Answer
Steven Smith Mon, 08/10/2009 - 12:49

You could put a translation profile on the ephone-dn that adds a 9.  This wouldn't be CCA supported, but it would mean not having to change the rest of your dial plan.

config t

ephone-dn 4

voice translation-profile outgoing faxadd9

voice translation-profile faxadd9

translate calling 4

voice translation-rule 4

rule 1 /\(^.*\)/ /9\1/

Something like that should work.  Use this page for a reference.
http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml
David Harper Mon, 08/10/2009 - 16:41

If I understand you correctly, the number is being provided from the application to the modem without a 9, the modem then dials that number without the 9 to the UC500 FXS port, and then the call needs to be routed out the SIP trunk.

Assuming I am correct, there are a couple of small errors in the above config (It must have been late when Steven typed his reply ;) ).  First, since from the perspective of the UC500, the call is coming in the FXS port, the translation-profile under the ephone-dn needs to be incoming, not outgoing.  ie:

ephone-dn 4

voice translation-profile incoming faxadd9

And second, the number that needs to be modified is the called number, not the calling number.  ie:

voice translation-profile faxadd9

translate called 4

Also, this will only work if the FXS port is set up as a User Phone under Analog Port Settings in CCA.  If it is set up as a Common  Area Phone or as a Fax, then the config is slightly different.

Cheers,

Dave.

esmythe@exclama... Fri, 01/06/2012 - 10:18

Hi David, how would this be accomplished with translation profiles for Common Area Phones or FAX lines?  I tried adding the above translation profile to the dial-peer but it did not change the dial 9 function.

-e

Actions

Login or Register to take actions

This Discussion

Posted August 10, 2009 at 12:41 PM
Stats:
Replies:4 Avg. Rating:5
Views:3786 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard