ISDN BRI configuration on 1841

Unanswered Question
Aug 10th, 2009
User Badges:
  • Bronze, 100 points or more

Hello, I was configuring a BRI on a 1841 & it appears that Layer 1 & 2 are up, but I still do not get any layer 3 active calls. I performed a "debug isdn q931 & one of the statements showed:


Aug 10 18:09:14.835: ISDN BR0/1/0 Q931: TX -> SETUP pd = 8 callref = 0x20

Bearer Capability i = 0x8890218F

Standard = CCITT

Transfer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Keypad Facility i = '18007931089'

*Aug 10 18:09:15.747: ISDN BR0/1/0 Q931: RX <- CALL_PROC pd = 8 callref = 0xA0

Channel ID i = 0x89.

*Aug 10 18:09:16.787: ISDN BR0/1/0 Q931: RX <- PROGRESS pd = 8 callref = 0xA0

Progress Ind i = 0x8A81 - Call not end-to-end ISDN, may have in-band info

Signal i = 0x01 - Ring back tone on ....


we are using 56k off of the BRI interface like the customers other sites, which are working:


interface BRI0/1/0

description backup

ip address negotiated

ip directed-broadcast

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer idle-timeout 300

dialer string 18007931089 class 56k

dialer load-threshold 1 either

dialer-group 1

isdn switch-type basic-ni

isdn spid1 21224226310101

isdn spid2 21224226320101

no peer default ip address

no fair-queue

no cdp enable

ppp authentication pap callin

ppp chap password 7 xxxxxx

ppp pap sent-username storeowd password 7 xxxxx

ppp multilink

ip route 0.0.0.0 0.0.0.0 BRI0/1/0 250

ip route 1.1.1.1 255.255.255.255 BRI0/1/0access-list 101 permit ip any host 1.1.1.1 log

access-list 101 permit tcp any any gt 1 log

access-list 110 remark Traffic from ATA

access-list 110 permit ip 10.193.249.11 0.0.0.4 any

access-list 111 remark Traffic destine to ATA

access-list 111 permit ip any 10.193.249.11 0.0.0.4

dialer-list 1 protocol ip list 101



It appears that the config should work. Would this be an issue on the service provide side with their setup?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
a-vazquez Fri, 08/14/2009 - 11:36
User Badges:
  • Silver, 250 points or more

Before using a router with an ISDN basic rate interface (BRI) interface, you must order a correctly configured ISDN BRI line from your local telecommunications service provider.


The ordering process varies from provider to provider and from country to country. However, some general guidelines apply:


•Ask for two channels to be called by one number.


•Ask for delivery of calling line identification, also known as Caller ID or automated number identification (ANI).


•If the router will be the only device attached to the ISDN BRI line, ask for point-to-point service and a data-only line.


•If you plan to connect another ISDN device (such as an ISDN telephone) to the ISDN BRI line through the router, ask for point-to-multipoint service (subaddressing is required) and a voice-and-data line.


http://www.cisco.com/en/US/docs/routers/access/1800/1841/software/configuration/guide/b_setup.html#wp53871

Anonymous (not verified) Mon, 08/17/2009 - 08:52
User Badges:

Thanks. I will check that out!

Actions

This Discussion