AA Authentication Banner problems

Unanswered Question
Aug 11th, 2009

I'm experiencing some problems with AAA authentication banners and banner logins.

I'm trying to use spaces and empty lines, but when login, all the lines are after eachother, no empty lines, no spaces.

The problem appears on a 3750 with IOS version 12.2(5)SE2

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Anonymous (not verified) Mon, 08/17/2009 - 16:11

To create a login banner, you need to configure a delimiting character, which notifies the system that the following text string is to be displayed as the banner, and then the text string itself. The delimiting character is repeated at the end of the text string to signify the end of the banner. The delimiting character can be any character in the extended ASCII character set, but once defined as the delimiter, that character cannot be used in the text string making up the banner.

Refer to the below URL for more info:


I am an encountering a similar situation, especially with new version on IOS on 2960G and 3560v2 switches.

I have a banner with portions that are centered appropriately, along with blank lines between

sections, however when it comes up on the screen, all of the text is left justified and there are no blank lines.  I am using the $ as a delimiter

.  Ever figure out what caused this?

b.julin Mon, 05/09/2011 - 14:00

If you look at a show run, does the banner text have the whitespace intact?  If not, then you need look no further into AAA...

b.julin Tue, 05/10/2011 - 06:51

Longshot: try using single or double quote as the delimeter?


This Discussion