MBGP to old BGP -- change family ipv4 to a VPNv4 rd?

Unanswered Question
Aug 11th, 2009

Boy this BGP stuff can get pretty deep.

I've managed to solve enough issues to get a solution to a particularly contorted VRF-based peering with an older non-MBGP neighbor. I won't get into details because this is a pretty unique situation.

However even though I have a solution that will meet my immediate needs, it struck me that it would have been a much more elegant solution if I could just have told MBGP that a particular non-MBGP neighbor should have it's ipv4 family addresses prefixed with a particular VPNv4 family/rd before being put into the RIB.

As it is I have ipv4 family routes being imported into a VRF via a prefix list, and no real interest in having them in the GLOBAL ipv4 family table, not that it matters. Eventually if I have to support a second non-MBGP neighbor, though, things could get ugly, since prefix lists won't cut it at that point.

So did I miss an obvious command somewhere that would allow that -- something like translate-updates except with VRF in mind? I tried a route map but it won't let you "set vrf" on incoming updates...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
mlund Wed, 08/12/2009 - 00:24


I maybe misunderstood things here.

My understanding of your description is, that you are peering with non-MBGP and want to get there prefixes into an vrf.

In that case, have your peering statements under the vrf-part not under the global config.

router bgp

neighbour < mbgp neighbours >


address-family ipv4 vrf < name >

neighbour remote-as

neighbour "whatever command you need"


b.julin Wed, 08/12/2009 - 05:15

I did try that -- I didn't know whether it was supposed to do what I wanted it to at the time, but I did try it.

I found that the BGP session would not come up unless there was an activate statement under the ipv4 family, and in that case the routes were appearing in GLOBAL, not in the designated VRF.

I'll have to play with that some more then, and see if I can't coax it into working. Thanks!

b.julin Thu, 08/13/2009 - 06:56

OK, the problem appears to have been that when you do this, the update-source has to be in the VRF in question. That and unfamiliarity with the behavior of the show commands.

I had been tricking out things to force communication between a lo0 in GLOBAL with the peer which was on a VRF interface, because the only way I could seem to get a BGP session up at all was with vanilla ipv4. That was interfering with the address-family ipv4 vrf stuff apparently.

So now it works swimmingly, without all those workarounds.

Thanks again!


This Discussion