DHCP issue

Unanswered Question
Aug 11th, 2009

Hi All:

I have having some problem with my DHCP.

These are the error messages i am getting.

*Aug 11 13:32:37.658: DHCPD: checking for expired leases.

*Aug 11 13:32:52.170: DHCPD: Sending notification of DISCOVER:

*Aug 11 13:32:52.170: DHCPD: htype 1 chaddr 0003.0dae.50b9

*Aug 11 13:32:52.170: DHCPD: remote id 020a0000c0a8800200000000

*Aug 11 13:32:52.170: DHCPD: circuit id 00000000

*Aug 11 13:32:52.170: DHCPD: Seeing if there is an internally specified pool class:

*Aug 11 13:32:52.170: DHCPD: htype 1 chaddr 0003.0dae.50b9

*Aug 11 13:32:52.170: DHCPD: remote id 020a0000c0a8800200000000

*Aug 11 13:32:52.170: DHCPD: circuit id 00000000

*Aug 11 13:32:52.170: DHCPD: requested address 10.119.3.58 is not on subnet 192.168.128.0.

*Aug 11 13:32:52.170: DHCPD: subnet [192.168.128.1,192.168.131.254] in address pool 128net is empty.

*Aug 11 13:32:52.170: DHCPD: Sending notification of ASSIGNMENT FAILURE:

*Aug 11 13:32:52.170: DHCPD: htype 1 chaddr 0003.0dae.50b9

*Aug 11 13:32:52.170: DHCPD: remote id 020a0000c0a8800200000000

*Aug 11 13:32:52.170: DHCPD: circuit id 00000000

*Aug 11 13:32:52.170: DHCPD: Sending notification of ASSIGNMENT_FAILURE:

*Aug 11 13:32:52.170: DHCPD: due to: POOL EXHAUSTED

*Aug 11 13:32:52.170: DHCPD: htype 1 chaddr 0003.0dae.50b9

*Aug 11 13:32:52.170: DHCPD: remote id 020a0000c0a8800200000000

*Aug 11 13:32:52.170: DHCPD: circuit id 00000000.

*******************************

And this is all the configuration related to dhcp.

Some of the user are getting disconnected and not getting IP againg i have to assign static IP from the reserve pool to get them working.

Even though there are many ip in the pool .

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.128.0 192.168.129.254

ip dhcp excluded-address 192.168.130.202

ip dhcp excluded-address 192.168.130.201

ip dhcp excluded-address 192.168.130.22

!

ip dhcp pool 128net

network 192.168.128.0 255.255.252.0

default-router 192.168.128.2

dns-server 192.168.128.10

lease infinite

interface GigabitEthernet0/0

description *** Connected to MAG-VSS-1 ***

ip address 192.168.132.2 255.255.252.0 secondary

ip address 192.168.128.2 255.255.252.0

ip route-cache flow

duplex auto

speed auto

media-type sfp

Pool 128net :

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 1022

Leased addresses : 279

Pending event : none

1 subnet is currently in the pool :

Current index IP address range Leased addresses

0.0.0.0 192.168.128.1 - 192.168.131.254 279

It never increase from 279

Any idea why ?

Chao

Vishwa

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ivarnhagen Wed, 08/12/2009 - 05:12

Hi Vishwa,

I would try the following suggestions what the excluded addresses (ip dhcp excluded-address) are concerned.(always remove the commands you configured previously since they do not overwrite):

Suggestion 1:

ip dhcp excluded-address 192.168.128.1 192.168.129.254

Suggestion 2:

ip dhcp excluded-address 192.168.128.1 192.168.128.255

ip dhcp excluded-address 192.168.129.1 192.168.129.255

Suggestion 3:

ip dhcp excluded-address 192.168.128.1 192.168.128.254

ip dhcp excluded-address 192.168.129.1 192.168.129.254

Another reason might be that some hosts have statically configured addresses, which may cause conflicts. Check the following link:

http://cco.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a00800f0804.shtml#casestudy2

hth

Ingo

vishwancc Thu, 08/13/2009 - 04:41

Hi Ingo ,

Thnks for the reply

I dont have issue with the excluded ip.

Even though i have enough IP in the DHCP pool after excluding PC are not taking that the maximun it goes is to 279 even the ip in pool are close to 1000

ivarnhagen Thu, 08/13/2009 - 05:09

Hi,

since I can't see anything wrong with your config. I thought the router/switch might be interpreting the "ip dhcp excluded-address 192.168.128.0 192.168.129.254" command incorrectly (normally the low address would start with the first useable ip 192.168.128.1). The 3 suggestions of mine are only ways to exclude this possibility. I would definately try the first one.

Is this error only occurring when 279 addresses have been leased?

If you could post output of "show version", "show ip dhcp bindings" and "show ip dhcp server" we might be able to find out more.

There is also a possibility of an IOS bug. So check the Cisco Bug database against your IOS version and your problem.

hth

Oleg Serstjuk Wed, 07/01/2015 - 01:49

just after fixing the same issue, had 100 IP addresses and ony 48 were leased.

 

deleting the ip excluded ranges and the DHCP pool and adding them back in resolved the issue

 

ronbuchalski Wed, 09/02/2009 - 14:59

Vishwancc,

While it is true that your ip pool has a maximum potential size of 1022 addresses (1024 minus network and broadcast addresses), you have excluded 515 addresses through your excluded address statements, leaving 507 potential addresses for the pool. How many do you need to allocate?

I think the clue behind the problem is indicated by the next address that is slated to be allocated. It is showing 0.0.0.0, which means that there are no more addresses to be assigned. Your debug information also indicates this, where it states that the pool is empty.

I just dealt with a similar problem today, and the cause was I had entered an exclude statement incorrectly, which effectively took out an entire pool.

Since you have supernetted four /24 address blocks together, I suggest you follow the advice of another poster and change your exclude statements. You should have:

ip excluded-address 192.168.128.1 192.168.129.255

(plus the three individual excludes)

This should start your DHCP pool at 192.168.130.0 up to the top of the range, minus the three individual excludes that you listed.

Also, you may want to try deleting all of the DHCP exclude statements before you re-do them, to insure that they have truly been removed. After you have done this, I also suggest issuing 'no service dhcp' and then reenable it ('service dhcp'). This will re-start the DHCP service. Turning off the DHCP service will not remove the DHCP configurations from your router.

Turn on the following to track what happens as you do the above:

debug ip dhcp server event

debug ip dhcp server packet

debug ip dhcp server linkage

The debugs may also give you a clue as to why it cannot allocate more addresses.

Hope this helps.

Ron Buchalski

vishwancc Thu, 09/03/2009 - 00:13

Hi RON,

I have not got the downtime to do these changes,once i get it i will implement it along witn the other action plan to check if the issue is resolved.

Chao

Vishwa

ronbuchalski Thu, 09/03/2009 - 06:11

Vishwa,

Please post an update when you have had a chance to test the suggested changes.

Ron Buchalski

Actions

This Discussion