snmp v1 for old devices

Unanswered Question
Aug 11th, 2009

we have an old router 2514 and we can snmpwalk by snmp v1 only.

How to force ciscoworks to use snmp v1 on this device only.

LMS3.1 CM3.2 RME4.2

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Joe Clarke Tue, 08/11/2009 - 20:58

LMS 3.1 will only use SNMPv1. More support for v2c by default was added in LMS 3.2. The only known issue is that Discovery will ONLY use SNMPv2c in LMS 3.1. This is fixed in LMS 3.2. What errors are you getting (and in what applications) managing this device? What version of code is it running?

albatli1977 Tue, 08/11/2009 - 21:38

The device not manage in RME at all (inventory / archive), and with command :

./opt/CSCOpx/objects/jt/bin/snmpwalk -v1 -c NMSreadonly -Iu -t 1 -m system -M /opt/CSCOpx/objects/jt/mibs is working fine but with -v2c not working,

also the device in HP-NNM is auto discovered by snmp v1

Joe Clarke Tue, 08/11/2009 - 21:42

RME 4.2 will only use SNMPv1 to manage the device. If you run an inventory collection for this device, what error do you get in the inventory collection job? What version of IOS is this router running?

albatli1977 Tue, 08/11/2009 - 21:49

please find below the output of the job log:

bash-2.05# more 1945.log

[ Wed Aug 12 08:50:42 AST 2009 ],INFO ,[main],Starting execution of job

[ Wed Aug 12 08:50:42 AST 2009 ],INFO ,[main],,validate,?,[email protected]

[ Wed Aug 12 08:50:43 AST 2009 ],INFO ,[main],,validate,?,

[ Wed Aug 12 08:50:43 AST 2009 ],INFO ,[main], CTM Object published is : [email protected] and with URN 1945

[ Wed Aug 12 08:50:43 AST 2009 ],INFO ,[main],1945 starting Daemon Manager communication thread

[ Wed Aug 12 08:50:47 AST 2009 ],INFO ,[main],,createJobEntry,358,Getting devices.

[ Wed Aug 12 08:50:50 AST 2009 ],INFO ,[main],,startInvCollection,74, Request ID returned from the server is : 1248585703939

[ Wed Aug 12 08:51:01 AST 2009 ],INFO ,[Thread-8],,processResult,69,got callback 17023

[ Wed Aug 12 08:51:01 AST 2009 ],INFO ,[Thread-2],,processPendingResults,86,processing 17023

[ Wed Aug 12 08:51:01 AST 2009 ],INFO ,[Thread-2], Result Description is : Device Collection Failed.

[ Wed Aug 12 08:51:02 AST 2009 ],INFO ,[Thread-2],Updating result for the device:

[ Wed Aug 12 08:51:02 AST 2009 ],INFO ,[Thread-2], Unpublished CSTM with URN: 1945

[ Wed Aug 12 08:51:03 AST 2009 ],INFO ,[Thread-2],Last statement in job execution


and sh version of the device:

RQ71160#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 3000 Software (IGS-I-L), Version 11.0(16), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1997 by cisco Systems, Inc.

Compiled Tue 24-Jun-97 12:20 by jaturner

Image text-base: 0x0301E644, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE

ROM: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (fc1)

RQ71160 uptime is 3 weeks, 3 days, 21 hours, 47 minutes

System restarted by power-on

System image file is "flash:igs-i-l.110-16", booted via flash

cisco 2500 (68030) processor (revision L) with 2048K/2048K bytes of memory.

Processor board ID 10253657, with hardware revision 00000000

Bridging software.

X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.

2 Ethernet/IEEE 802.3 interfaces.

2 Serial network interfaces.

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

Joe Clarke Tue, 08/11/2009 - 21:57

This is what I thought. I'm betting this device doesn't support the cardSlots and cardContainedByIndex objects in the OLD-CISCO-CHASSIS-MIB. The problem is not with SNMP version, but rather lack of proper instrumentation to support this device. I was working with another customer recently who had the same problem. I recommend an upgrade to at least 11.1 based code.


This Discussion