Any ideas why this host does not work on some switchports?

Answered Question
Aug 12th, 2009
User Badges:

Imagine I have a 2950 switch. Switch is connected via port fa0/48 to 3750 Layer 3.


On 2950switch, switchportports fa0/10, switchport access vlan 100. A host is connected to that port and I can ping it OK.


Then technician attemtpts to connect same functional host to ports fa0/11 or fa0/12 or fa0/13 on 2950switch and then host does not communicate (ping times out) when it is connected to any of those ports. Such switchports are configured with identical VLANs settings, duplex, etc.


Any ideas on what could be wrong here? I thought that it could be unlikely all three ports fa0/11-fa0/13 went bad on that 2950switch...

Correct Answer by Edison Ortiz about 7 years 10 months ago

I see egress traffic but no ingress traffic. I suspect a bad cable. Are you using the same cable while moving from one switchport to another?


Is the device connecting directly to the switch or going via some kind of patch panel?


Try:


(config)#default interface f0/11

(config)#interface f0/11

(config)#switchport mode access

(config)#switchport access vlan 100




__


Edison.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
jbrenesj Wed, 08/12/2009 - 10:23
User Badges:
  • Silver, 250 points or more

Any other know working hosts work on those ports?

news2010a Wed, 08/12/2009 - 10:41
User Badges:

Connected another host;same behavior. It works on port fa0/10 and it does not work on port fa0/11.

Edison Ortiz Wed, 08/12/2009 - 11:53
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

What's the status of the interface?


up/up?


Check for err-disabled status.


__


Edison.

news2010a Wed, 08/12/2009 - 12:19
User Badges:

Here is the actual output from the bad port. The only wrong info I noticed is the "2 input errors, 2 CRC". Yes, it is up/up.

Notice I inherited 'bpdufilter' config and I know that should be removed, but I do not believe that is causing the problem.


2950#show int fa0/11

FastEthernet0/11 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0027.e07d.ac59 (bia 0027.e03d.ax59)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 1000 bits/sec, 2 packets/sec

0 packets input, 331 bytes, 0 no buffer

Received 0 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

2 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

41654 packets output, 2862803 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out




!

interface FastEthernet0/10

switchport access vlan 100

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

end


2950#show run int f0/11

Building configuration...


Current configuration : 149 bytes

!

interface FastEthernet0/11

switchport access vlan 100

spanning-tree portfast

spanning-tree bpdufilter enable

spanning-tree bpduguard enable

end



Correct Answer
Edison Ortiz Wed, 08/12/2009 - 12:23
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I see egress traffic but no ingress traffic. I suspect a bad cable. Are you using the same cable while moving from one switchport to another?


Is the device connecting directly to the switch or going via some kind of patch panel?


Try:


(config)#default interface f0/11

(config)#interface f0/11

(config)#switchport mode access

(config)#switchport access vlan 100




__


Edison.

news2010a Wed, 08/12/2009 - 12:36
User Badges:

Same cable and host that worked on port fa0/10 was connected directly to port fa0/11 and then it did not work.


Let me try input the config on the switchport and see. I am aware that I inherited the lack of switchport mode access as well and that should be included, although 'mode access' should not cause issues related to this problem.


MUHAMMAD SHAHEEN Wed, 08/12/2009 - 12:19
User Badges:
  • Silver, 250 points or more

Hi,


can you provide copy of the config from port fa0/10 to fa0/14 ? this may help us to understand a bit more.


thanks

Shaheen

Leo Laohoo Wed, 08/12/2009 - 14:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Edison's right. Traffic is only one way. Can you plug the ping-able host to Fa 0/11 using the other cable and compare the result?

news2010a Wed, 08/12/2009 - 14:31
User Badges:

I did that and cable which worked on fa0/10 device is same cable on device on fa0/11; problem persists.


Also, tech onsite tells me a couple of ports fa0/20 and fa0/24 (which does not work either) is showing amber LED on - and there is nothing connected to ports at all. It really seems we have a faulty hardware unless you can think of something else to do.

Edison Ortiz Wed, 08/12/2009 - 17:05
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Faulty hardware indeed, no need to waste cycles on this, call your Cisco sales and get a replacement :)


chinkevi_2 Wed, 08/12/2009 - 18:43
User Badges:

you can use cross over cable to plug directly between 2 ports to test if the port is faulty.

Actions

This Discussion