Internal routing problem - 877W

Unanswered Question
Aug 12th, 2009

I'm trying to configure in a 877W a connection to a DSL. With the configuration below, I can ping from the router any Internet address but from any PC on the network I can't. Can somebody tell me what is wrong?



no aaa new-model

!

!

dot11 syslog

no ip source-route

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.15.1

!

ip dhcp pool dpool1

import all

network 192.168.15.0 255.255.255.0

default-router 192.168.15.1

dns-server xx.xx.xx.xx

!

!

no ip domain lookup

ip name-server xx.xx.xx.xx

ip name-server xx.xx.xx.xx

!

archive

log config

hidekeys

!

interface ATM0

no ip address

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

pvc 8/32

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.15.1 255.255.255.0

ip access-group 100 in

ip nat inside

ip virtual-reassembly

!

interface Dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 0 xxx

ppp pap sent-username xxx password 0 xxx

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 0.0.0.0 255.255.255.0

access-list 1 permit 192.168.15.0 0.0.0.255

access-list 100 permit ip any any

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Wed, 08/12/2009 - 13:55

Can you remove "ip nat outside" from the ATM0 interface config and add "ip nat outside" under the Dialer0 interface and then retest.


Jon

coruna_74 Wed, 08/12/2009 - 16:29

Now I can ping Internet addresses from computers inside the network and I can also open connections to ftp servers, but I cannot open web sites through the IE. Any idea?

coruna_74 Thu, 08/13/2009 - 01:55

I have made a few changes in the configuration, and now I've got new problems.


With the conf below the Internet access through LAN goes real slow and the WLAN does not even appear at the computers availables WLANs list.


Any suggestion?


version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cisco

!

boot-start-marker

boot-end-marker

!

logging buffered 51200

logging console critical

enable secret 5 xxx

!

no aaa new-model

!

dot11 ssid cisco1

vlan 1

authentication open

authentication key-management wpa

wpa-psk ascii 0 xxx

!

no ip source-route

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.15.1

!

ip dhcp pool dpool1

import all

network 192.168.15.0 255.255.255.0

default-router 192.168.15.1

dns-server xx.xx.xx.xx

!

!

no ip domain lookup

ip name-server xx.xx.xx.xx

ip name-server xx.xx.xx.xx

!

!

!

username xxx privilege 15 password 0 xxx

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface ATM0

no ip address

ip virtual-reassembly

no atm ilmi-keepalive

pvc 8/32

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

no ip route-cache cef

no ip route-cache

!

encryption vlan 1 mode ciphers tkip

!

broadcast-key vlan 1 change 45

!

!

ssid cisco1

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

power local cck 13

power local ofdm 13

power client 13

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

bridge-group 1

!

interface Dialer0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 0 xxx

ppp pap sent-username xxx password 0 xxx

!

interface BVI1

ip address 192.168.15.1 255.255.255.0

ip access-group 100 in

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip http server

ip http authentication local

ip http secure-server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 remark SDM_ACL Category=18

access-list 1 permit 192.168.15.0 0.0.0.255

access-list 100 permit ip any any

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

Actions

This Discussion