How do I upgrade IPS from 6.1(1)E3 to 7/0(1) on ASA?

Unanswered Question
Aug 12th, 2009


I am using ASA-SSM-10 IPS module and it is running version 6.1(1)E3, how can I updat this to version 7.0(1). I am also using the Cisco Express IPS Manager.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mkodali Thu, 08/13/2009 - 08:11

You need to use the upgrade package IPS-K9-7.0-1-E3.pkg. You can download this package from

Once you download the package to your local server you can use upgrade command on SSM-10 CLI

qssm-229(config)# upgrade ftp://@:///IPS-K9-7.0-1-E3.pkg

Common upgrade methods and other details are available on this link :

Hope this helps

whiteford Fri, 08/14/2009 - 01:43


I upgraded it using the Cisco IPS Express manager in the end.

Problem I have now is the Global correlation is failing and I don't seem to be getting any real-time high alerts. The CPU is normally 100% but now only 5%, it is like it's not monitoring anymore.

mkodali Fri, 08/14/2009 - 05:49

For Global Correlation to function, you must have either a DNS server or an HTTP proxy server configured. You may need a proxy server to download Global Correlation updates if you use proxy in your network. If you are using a DNS server, you must configure at least one DNS server and it must be reachable for Global Correlation updates to be successful. More details on this link

You will also need a valid license for the above tasks.

Once you see updates successful you can tune the global correlation service options on IME as per the details in this link :

However, not having global correlation working should not impact regular monitoring.

whiteford Fri, 08/14/2009 - 05:53

The packet tracer from the ASA proves that is not being block but rules etc.

If it is a license issue then I would think my signatures wouldn't get updated every day?


This Discussion