Linksys RV082 Unusable after 'upgrade' to 2.0.0.19

Unanswered Question
Aug 13th, 2009

I recently had my Comcast service upgraded to 16/2; the service Tech actually demo'd 25/8 with a direct connection to the modem. I thought I'd upgrade my RV082 from 1.3.9.8 to 2.0.0.19. The upgrade went uneventfully and the router worked afterwards but web sites (nyt.com, wundermap on wunderground.com) takes 10s of seconds to load now and my speeds via the router are 5/7. I tried direct connection to the modem and got 27/9 so the issue is clearly the router. I tried to go back to the previous version via the GUI menus but it didn't change the version number. Clearly 2.0.0.19 is junk. What can I do to get back to a usable system other than buy a new router?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tedmawson Wed, 08/19/2009 - 11:41

I read the notes before upgrade and knew that I would not be able to go back to 1.x.x.x As I said before, the GUI offers the option but it doesn't work.

My issue is simple; 2.0.0.19 is a bad version and, until it is fixed OR, I am offered some way to get back to vn 1.x.x.x, my router is unusable.

I have now got a D-Link DGL 4100 router that is giving me 27/7 with firewall SPI switched on.

I wonder if Cisco cares that they have released a firmware upgrade that hoses a $300 router and doesn't offer any path back to the working version?

Actions

This Discussion