call not going thru

Unanswered Question
Aug 13th, 2009

i hav 2811 router with hwic-adsl and vic2-fxo. the vpn and internet is working fine everything is pinging n all but whenever i call there is no tone and incoming calls are coming thru but thn no audio. i think this is a routing prob. please help me urgent thanku

!

!

!

voice-card 0

!

!

crypto pki trustpoint TP-self-signed-2459928928

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2459928928

revocation-check none

rsakeypair TP-self-signed-2459928928

!

!

crypto pki certificate chain TP-self-signed-2459928928

certificate self-signed 01

3082023E 308201A7 A0030201 02020101

quit

!

!

username xxxxx privilege 15 secret 5 xxxxx

archive

log config

hidekeys

!

!

crypto isakmp policy 1

encr 3des

authentication pre-share

group 2

crypto isakmp key xxxxx address 0.0.0.0 0.0.0.0

!

!

crypto ipsec transform-set ESP-3DES-SHA2 esp-3des esp-sha-hmac

!

crypto dynamic-map SDM_DYNMAP_1 1

set transform-set ESP-3DES-SHA2

match address 103

!

!

crypto map SDM_CMAP_1 65535 ipsec-isakmp dynamic SDM_DYNMAP_1

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex full

speed auto

no mop enabled

!

interface FastEthernet0/0.1

description $ETH-LAN$

encapsulation dot1Q 1 native

ip address 10.2.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1

description $ETH-LAN$

no ip address

shutdown

duplex auto

speed auto

!

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

!

interface ATM0/0/0.1 point-to-point

pvc 0/50

pppoe-client dial-pool-number 1

!

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxx

ppp chap password 0 xxxxx

ppp pap sent-username xxxxx password 0 xxxx

crypto map SDM_CMAP_1

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http secure-server

!

!

ip nat inside source list 2 interface Dialer0 overload

ip nat inside source route-map SDM_RMAP_1 interface Dialer0 overload

!

access-list 1 remark INSIDE_IF=FastEthernet0/0.1

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.2.1.0 0.0.0.255

access-list 103 remark SDM_ACL Category=4

access-list 103 remark IPSec Rule

access-list 103 permit ip 10.2.1.0 0.0.0.255 10.2.2.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

route-map SDM_RMAP_1 permit 1

match ip address 101

!

!

!

!

control-plane

!

!

!

voice-port 0/1/0

cptone AE

connection plar opx 2101

caller-id enable

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

ccm-manager fax protocol cisco

!

mgcp fax t38 ecm

!

!

!

dial-peer voice 1 pots

destination-pattern 8T

port 0/1/0

!

dial-peer voice 6 voip

destination-pattern 22..

session protocol sipv2

session target ipv4:10.2.2.2

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 7 voip

destination-pattern 9T

session protocol sipv2

session target ipv4:10.2.2.2

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

!

!

!

telephony-service

em logout 0:0 0:0 0:0

max-ephones 35

max-dn 35

ip source-address 10.2.1.1 port 2000

auto assign 1 to 35

system message Chapal

max-conferences 8 gain -6

transfer-system full-consult

secondary-dialtone 8

create cnf-files version-stamp 7960 Aug 11 2009 12:23:17

!

!

ephone-dn 1 dual-line

number 2101

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mustafa_chapal Thu, 08/13/2009 - 09:32

the calls to other extensions under this cme are fine but the outgoing calls over vpn to other cme fail and incoming calls that come over vpn have no audio.

Paolo Bevilacqua Thu, 08/13/2009 - 09:38

VPN is not set correctly, and/or some kind of firewall/ACL is blocking audio and outgoing calls.

mustafa_chapal Thu, 08/13/2009 - 09:46

so how should i solve it. i think that if there is any way of removing source in the ping and directly ping to 10.2.2.0 network from 10.2.1.1 interface on the router

Paolo Bevilacqua Thu, 08/13/2009 - 09:48

What are you talking about ?

Your VPN must be transparent, each phone and CME must be able to ping the other side.

Just to be clear, is this a lab and you're a student ?

mustafa_chapal Thu, 08/13/2009 - 09:49

firewall is disabled but as the cme and vpn are on the same router; the router is unable to forward it directly to the 10.2.2.0 network. before it was fine when i had cisco 877 router for adsl and vpn while 2811 router for cme only so before 2811 forwarded the calls to the interface of cisco 877 which then forwarded further to the other site over vpn

Actions

This Discussion